Need help with registry using PlatformUtilities


#1

I’m trying to use the registry to store a few simple bool values. I’m trying to use PlatformUtilities::setRegistryValue and getRegistryValue with not much success. I’ve passed in the Key path and a value but i’m not seeing any changes in the registry. so i need to have a string value created in the registry before i can change it with setRegistryValue() ?


#2

really? I just tried it myself and it worked fine, creating all the subkeys it needs…

this is what I did:

[code] PlatformUtilities::setRegistryValue (T(“HKEY_CURRENT_USER\blah\blah\blah2”),
T(“xyz”));

    DBG (PlatformUtilities::getRegistryValue (T("HKEY_CURRENT_USER\\blah\\blah\\blah2")));

[/code]

are you trying to write to a bit of the registry that where you don’t have permission?


#3

Well i notices that all my \ where getting parsed out so i tried the double backslash \ watched the correct string get passed in to your setResgistry Method but i can’t confirm that anything has been added or changed.

I believe i have full access to the folder I’m trying to create a key in
is there something else i need to do to gain permission to the registry?


#4

don’t know much about registry permissions, but these methods definitely work, I’ve used them many times before. You can always step into the setRegistryValue method and see where it fails.


#5