Noob - Not generating .dll or .vst


#1

Hi,

Appologise if this is covered but I can’t find the answer…

Day 1 of learning how to make an audio plugin using JUCE and VS2017

I’ve got so far as to compile my plugin in VS2015 and it shows me my little hello world window. No errors, all good.

But it doesn’t create a .dll or .vst file to use in a DAW. I’m using ‘Everything’ to search my entire drive for the file in case it’s going somewhere else but nothing…

I think it is because when I compile I have Local Windows Debugger selected, but I don’t have VST as an option and cannot work out how to add it.

What have I failed to do?!

Any help appreciated


#2

Maybe have a look at your Projucer settings:

If copy step is deactivated, it should end up in the default locations, that you see there greyed out. You can use the %-signed environment variables in your windows file explorer:
%ProgramW6432%\Steinberg\Vstplugins
%CommonProgramW6432%\VST3

If copy is enabled, it should be copied to the path specified there. If that doesn’t work, check if you have write permissions on that path, maybe?

Good luck!


#3

Hi Daniel,

Thanks for your quick response

That all looks right to me, I don’t think it’s a path thing though, I don’t think it is making the file at all… I can find the .exe it is generating but no .vst

image

Is that the right kind of build?

Thanks


#4

Does it say “Audio Plug-in” next to Project Type in your Project Settings?Untitled


#5

Yup…

image


#6

Found it!

So I didn’t realise but building a standalone plug-in will only do that… it won’t do both.

Unticked and it created my .dll

image

Thanks a lot for your help!