Old project in Producer still shows VS2019 and VS2019 as selected exporter. This is a problem

Hello all,

So I have opened up an old project in Producer and it shows VS2019 as the selected exporter. I uninstalled VS2019 awhile ago and switched to VS2022, but I cannot select it for this project. Other newer projects correctly detect it. I could make a new project / jucer but perhaps there is a better way to solve this?

The reason why this is a problem is because I also cannot select the v143 toolset in Producer, so every time I open the project in VS2022 it tells me that I need to retarget the solution. So I retarget, save, close, reopen and its back to needing to be retargeted. In the exporters drop down in Producer I can see only these options:-


There is no v143 in the list.

So my question is… is it possible to migrate the project in Producer somehow that I am missing, or do I have to make a new project?

Thanks :).

No need to make a new project. You can add the vs2022 exporter. and if you don’t need it, you can delete the vs2019 exporter.

Here is my special trick, if you have a lot of specific settings in the exporter (no guarantee, make a backup first). Open the *.jucer file in a text-editor and replace all “VS2019” with “VS2022” → resave in projucer → voilà

1 Like

lovely. i was going to resort to that next haha. i was wondering if there was a way within Producer itself though.

ah yes! i didn’t see that! :smiley: that is excellent.