OpenGL


#1

i am getting trouble with OpenGL. when i run demo of OpenGL i got that break in void checkGLError (const char* file, const int line) which is function of juce_opengl.cpp.
This same thing also happening when i run any other application of OpenGl which runs correctly on other PC. help me out please…


#2

If openGL is broken on your machine, you need a GL forum, not a JUCE one…


#3

Dear Jules,

I used your canary in my coal mine. The canary died. What’s wrong with your canary?


#4

Thanks for replying but i am doing juce and in that i am using OpenGLRenderer component for rendering opengl coponent.


#5

You said that all GL applications are broken. Did you mean all juce GL applications are broken?

If so, obviously there’s no point expecting a reply unless you actually give some useful information. I mean, you didn’t even give a stack trace or say what OS you’re running :roll:


#6

let me brief you about my problem… i am using WindowsXP and Visual Studio 2010… i am running JuceDemo but, when i run demo of juceOpenGL(or any other code that include OpenGLRenderer for rendering OpenGL in juce). i am getting break point in function [quote]void checkGLError (const char* file, const int line)[/quote] it’s function of juce_opengl. this is working on other PC having Windows7 and VS2010…

here is call stack…
JuceDemo.exe!juce::checkGLError(const char * file, const int line) Line 148 + 0x56 bytes C++
JuceDemo.exe!juce::OpenGLContext::CachedImage::renderFrame() Line 151 + 0xf bytes C++
JuceDemo.exe!juce::OpenGLContext::CachedImage::run() Line 266 + 0xb bytes C++
JuceDemo.exe!juce::Thread::threadEntryPoint() Line 98 C++
JuceDemo.exe!juce::juce_threadEntryPoint(void * userData) Line 106 C++
JuceDemo.exe!juce::threadEntryProc(void * userData) Line 119 + 0x9 bytes C++
JuceDemo.exe!_callthreadstartex() Line 314 + 0xf bytes C
JuceDemo.exe!_threadstartex(void * ptd) Line 297 C


#7

Your line numbers don’t match what I’ve got here. Please don’t report problems unless you’ve got the latest version of the code…

And check that your card supports GL2.0… There are minimum requirements these days, so if it’s an old card, of course some operations will fail.