Plugin Host assert failure


#1

I just upgraded from JUCE 4.2.2 to 4.2.3 and now I’m hitting an assertion failure in AudioProcessor::beginParameterChangeGesture.

When I try to move some of the sliders in my plugin, AudioProcessor::beginParameterChangeGesture says that the parameterIndex is out of range. I have 89 parameters but in that method, the parameterIndex is 1629 or something else, depending on what slider I try to move. I’m positive that I don’t have 1629 parameters.

I’ve tried running some other plugins by other manufacturers in Plugin Host and it seems to crash similarly depending on what slider is moved. But if I try running my plugin in MainStage, it’s fine.

This is rather odd. Any ideas out there?


#2

#3

Which other plugins did you try running. This would help reproduce the problem.


#4

Sorry, now I can’t get any others to reproduce it. I might have been mistaken.

So, is the issue with the Plugin Host code? Or 4.2.3?


#5

I’m not really sure and I’m having trouble reproducing this. Can you modify the code of the JuceDemoPlugin (or any other plug-in sample in JUCE) to re-produce this problem?


#6

I just had Projucer save and export the Demo Plugin. Built the plugin and then ran Plugin Host. When I added the Demo Plugin, I got this message:

WARNING: 140: This application, or a library it uses, is using the deprecated Carbon Component Manager for hosting Audio Units. Support for this will be removed in a future release. Also, this makes the host incompatible with version 3 audio units. Please transition to the API’s in AudioComponent.h.

As soon as I tried to move a rotary slider, I hit the same assert, “out of range parameter index”.

parameterIndex = (int) 3165055

When I did a “po getNumParameters();” in the debugger it returned 2.


#7

Hi pizzafilms, thanks for spotting this bug. I’ve just released a hot-fix for this on master and develop.


#8

Working well here. Thanks.