PluginHost doesn't compile with Mac OSX Xcode 3.0 (OSX 10.5)


#1

Hi,
I just detected a little issue with uint32 which is declared in the JUCE_NAMESPACE and is not accessible from certain files.

Adding:
#define uint32 JUCE_NAMESPACE::uint32
#define uint8 JUCE_NAMESPACE::uint8
in the files that give compilation errors (FilterGraph.h, juce_VSTPluginInstance.cpp) , does the job.

BTW the 10.5 SDK and the Architecture (i386) also have to be changed in the project settings.


#2

Ah, thanks. I’ve not tried compiling that project since I installed 10.5, so I’ll have a look.


#3

I’ve just encountered this too with the latest Juce SVN tip… having to build with 10.4 (or 10.3.9) SDK target.

HTH!

Pete


#4

Yes, I’ve fixed a couple more of those, will check it in shortly…


#5

Cheers! I was also caught-out by the one where I needed to modify the juce project to build for ppc architecture (not just intel). That one gets me everytime I upgrade. :slight_smile:


#6

I’m now having to do:

in an App on Mac using the libs (not amalgamated),
uint32 also defined in cssmconfig.h

updated to the Juce tip and I’ve tried various combinations of SDK settings.