Projucer 5.4.1 doesn't allow user modules to be inside juce modules folder?


#1

Hello guys,

so far I put my custom modules inside the same folder where the juce modules reside. After update to JUCE version 5.4.1 I had to realize that the projucer doesn’t allow my custom modules to reside in the juce modules folder any longer.

I hope that the following steps help to reproduce the problem:

  1. I updated JUCE to version 5.4.1 and (re-) built the projucer.
  2. I created a “user_modules” folder beside the juce “modules” folder.
  3. I created a “user_dummy_module_1” and added it to the folder “user_modules”.
  4. I created a “user_dummy_module_2” and added it to the folder “modules”.
  5. I started the projucer an set the global paths:
    • JUCE Modules --> “…/modules” and
    • User Modules --> “…/user_modules”.
  6. I created a new Audio Plug-In in the projucer.
  7. I added my module via “+” --> “Add a Module” --> “Global user modules path” --> “user_dummy_module_1”.
  8. I tried to add my module via “+” --> “Add a Module” --> “Global JUCE modules path” --> “user_dummy_module_2”:

  1. Strangely a file browser opened and I had to select the module manually:

  2. After selecting it the module showed up in Modules list. But when I clicked on the item a red comment “Cannot find this module at the specified path!” appeared in the right panel:

  1. In contrast: When I click on the “user_dummy_module_1” (its files are located in the “custom_modules” folder) the details of the module appears in the right panel - as expected:

I am using Window 10 and built the projucer with VS2017.

Can anybody tell me if this is the “normal” behavior or did I do something wrong or is something wrong with the projucer?

Thanks in advance!


#2

Why are you putting non-JUCE modules in the JUCE module folder in the first place? They will be wiped when you re-pull or update your JUCE version.


#3

I tweaked some JUCE classes - so I’m working with “my own” JUCE. After pulling I copy the updated modules manually to my folder.

I had the non-JUCE modules in the JUCE modules folder for serveral years now and everything worked fine. When I load a project with the new projucer my modules showing the above alert message.

Why it should not be possible to have JUCE and non-JUCE Modules in the same folder?