Projucer: How to change binary location VST, VST3, for VS2017

#1

For the debug profile of VS2017 at the moment they’re greyed out:
I’m trying to build them to a particular folder, but they’re not editable in Projucer?

0 Likes

#2

Well, I managed to add a post build command:
XCOPY "$(SolutionDir)$(Platform)\$(Configuration)\VST\myplug.dll" "C:\Program Files\VSTPlugins\myplugsdir\" /S /Y
I’m curious what the Binary Location fields in Producer actually do…
Thanks for any comments.

0 Likes

#3

You need to set “Enable Plugin Copy Step” to “Enabled” (it is “Disabled” by default):

0 Likes

#4

You may also need to alter the permissions of those destination folders so that VS can write to them.

0 Likes

#5

Thanks for the replies.
I’m using the built in copy step now.
I did encounter the permissions issue previously when I started developing on Windows 10.

0 Likes

#6

It seems that there is no “VST Binary Location” anymore (Projucer v5.4.3).
Is it really so obsolete? As I know, there is still no support for VST3 in Ableton Live.

0 Likes

#7

If you don’t already have a license you can’t distribute VST2 plugins anyway. If you do, the headers are in the VST3 SDK (before version 3.6.11 iirc).

Live beta 10.1 supports VST3.

1 Like

#8

“VST Binary Location” has been renamed to “VST (Legacy) Binary Location”.

0 Likes

#9

I mean, there is no “VST (Legacy) Binary Location” too in my Projucer (v5.4.3)

0 Likes

#10

You need to select “VST” in the “Plugin Formats” field of the project settings.

By default, “VST3”, “AU”, and “Standalone” are selected:

1 Like

#11

Oh, thanks a lot! That’s what I need.

1 Like