Projucer new windows don't appear on Arch


#1

Hi,
I’m having problems with Projucer where many of the buttons don’t do anything; it appears likely related to when it tries to open new windows, e.g. for file choosing. for example, when I go to “File”->“Open”, the “Open Existing Project” button briefly flashes and then nothing happens, or when I hit the “Open Existing Project” button, sometimes I see what looks like the file chooser dialogue for an instant but then it’s gone. ultimately I’m unable to get far enough through the wizard to open or start a project before encountering one of these problems.

I’m running Arch Linux. the problem appears with the current head of the JUCE github repo, and the current JUCE version distributed as a zip file (looks like 4.2.1.)

based on some existing forum threads I’ve explored some possible explanations / workarounds although none have applied or worked for me.

I have zenity installed.

I currently use Xmonad, although I’ve tested with a non-tiling window manager (TWM) and that doesn’t seem to help.

I tried disabling native file chooser dialogues (by adding -D JUCE_DISABLE_NATIVE_FILECHOOSERS="1" to the Linux Makefile CPPFLAGS, and also via the useOSNativeDialogBox arg of the FileChooser constructor just in case the former didn’t work) but that didn’t have a noticeable effect.

I tried using this fork as mentioned on this thread but that didn’t seem to help.

any ideas?
thanks!


#2

I just discovered an interesting detail and potential workaround actually. if I go to “File”->“Open” repeatedly, every once in a while it does actually successfully create the “Open File” dialogue… it seems to work on the order of one every 10 times or so.


#3

This looks like a bug we fixed on the latest develop branch. Can you re-test it on develop?


#4

hi Fabian,
thanks for your response! the develop branch indeed seems to fix the issue. there is one case in which the problem still occurs, which is when I’m using a tiling window manager (xmonad) and I have the JUCE_DISABLE_NATIVE_FILECHOOSERS flag set in the Projucer makefile. however, as long as those conditions are not both true, the file chooser windows and Projucer GUI now seem to work without issue.

FWIW, I have also noticed that on the master branch, the bug does not occur if I’m on a non-tiling window manager (e.g. TWM) and I have the JUCE_DISABLE_NATIVE_FILECHOOSERS flag set.