Rez failed to find AUResources/AUResources.r, since update to OSX 10.10 / Xcode 6.1


#1

Hi,

 

I am working on a plugin, and it was building and working fine until I updated to OSX 10.10 and to Xcode 6.

Now, it seems that rez can't read the AUResources.r file although it is located where rez is trying to read it. I tried to install XCode 5 back but I get the same error. I also to create a new project with the Introjucer but it didn't work.

Here is the error I get:

 

failed to find AUResources/AUResources.r

/Users/pixelized/Work/AudioGaming/SVN/trunk/externals/juce_3.0.4/modules/juce_audio_plugin_client/AU/juce_AU_Resources.r:49: ### /Applications/Xcode 6.app/Contents/Developer/usr/bin/Rez - SysError 0 during open of "AUResources.r".

Fatal Error!

/Users/pixelized/Work/AudioGaming/SVN/trunk/externals/juce_3.0.4/modules/juce_audio_plugin_client/AU/juce_AU_Resources.r:49: ### /Applications/Xcode 6.app/Contents/Developer/usr/bin/Rez - Fatal Error, can't recover.

AUResources.r: ### /Applications/Xcode 6.app/Contents/Developer/usr/bin/Rez - Since errors occurred, /Users/pixelized/Library/Developer/Xcode/DerivedData/Test-dlzoklfkbaswuwelxrznwfaclecw/Build/Intermediates/Test.build/Debug/Test.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc's resource fork was not written.

Command /Applications/Xcode 6.app/Contents/Developer/usr/bin/Rez failed with exit code 3

 

Does someone have any idea of where it could come from ?

Thank you.


#2

When you upgrade Xcode it overwrites the Extras/CoreAudio folder, so you have to add one again.

http://www.juce.com/forum/topic/aus-xcode


#3

Thank you very much !


#4

Hi all, 

 

I've encountered rez issues in the past after various updates and its always been fixed by adding an Extras folder under Develoer in the Xcode app contents and including the CoreAudio sdk. 

 

Hoever I've follwed these steps as per norm and just cannot get the demo plugin to build (I have a working synth project im developing on my macbook 10.9.5 with Xcode 6.1 that I want to put on the 10.10 machine)

 

Going to developer tools doesn't list a specific AU tools or CoreAudio SDK for Xcode 6.4

 

Has anyone else encountered this / been able to fix that pain in the butt rez issue ? 

 

Wondering if anyone can point me to a link for the correct CoreAudio SDK version that I should be using. I wonder if apple will ever sort these AU headaches out....

 

{EDIT} I'm able to build AU plugins from scratch now without any problems by the looks of it after a little work but the Demo Plugin still refuses to build so it looks like some agro between introjucer and Xcode as the CoreAudio SDK is set correctly. Doesn't seem to resolve even with pulling a fresh copy of Demo Plugin project from GitHub and running cleans etc on Xcode project. Not a major issue for me as hopefully past the need for the demo now but odd I can't get it to build. {EDIT}


#5

Hi all,

I’m facing this “Xcode 6.4 and Rez error” issue when I build a AU plug-in.
(I can build a VST plug-in though…)

Does anyone know about this problem?

[EDIT]
I’ve solved this problem by below link steps.


(Get CoreAudio, Create synblic link into Xcode folder.)

Thanks!


#6

You don't have to patch XCode anymore, you can enter a SDK Path in Introjucer and put the AU-SDK in a separte folder.

 


#7

And we're also planning on embedding the patched Apple CoreAudio files directly in the JUCE codebase, so there'll be no need for you guys to even know they exist. (We recently noticed that they're actually under a permissive license so it's OK for us to redistribute them)


#8

Yay!  :) One more pain-in-the-arse-to-get-started step sorted ;-)


#9

We just committed that change. You no longer need to download/install/patch Apple's "Core Audio Utility Classes" to compile AU plugins - it should just work out of the box with a fresh Xcode install.