Can't rez on AUResources.r


#1

I’am trying to compile the demoplugin for mac OSX 10.6 under XCode.
During the linking process, xcode tells me that he can’t rez on AUResources.r

I’ve tried to add AUResources.r in the Rez Search Path but i’am still unsuccessful, any idea ?

Denis.


#2

Well, that’s certainly the problem - if it doesn’t work it must just be that you’ve given it the wrong path or something…


#3

I checked many times.
My rez search path contains the full path to AUResources.r :
/Developer/Examples/CoreAudio/AudioUnits/AUPublic/AUBase.

Still unable to compile.


#4

Maybe actually telling us the error message would be a good idea?


#5

Here is the error message given by Xcode :

Rez build/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc …/…/…/wrapper/AU/juce_AU_Resources.r
cd “/Users/drolland/juce/extras/audio plugins/demo/build/mac”
/Developer/Tools/Rez -o “/Users/drolland/juce/extras/audio plugins/demo/build/mac/build/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc” -d SystemSevenOrLater=1 -useDF -script Roman -d ppc_$ppc -d i386_YES -d ppc64_$ppc64 -d x86_64_$x86_64 -I /System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Versions/A/Headers -I /Developer/Examples/CoreAudio/AudioUnits/AUPublic/AUBase -arch i386 -i “/Users/drolland/juce/extras/audio plugins/demo/build/mac/build/Debug” -i . -i /Developer/Examples/CoreAudio/AudioUnits/AUPublic/AUBase/AUResources -i “/Users/drolland/juce/extras/audio plugins/demo/build/mac/…/…/…/wrapper/RTAS” -i “/Users/drolland/juce/extras/audio plugins/demo/build/mac/…/…/src” -i /Developer/Examples/CoreAudio/AudioUnits/AUPublic/OtherBases -i /Developer/Examples/CoreAudio/AudioUnits/AUPublic/Utility -i /Developer/Examples/CoreAudio/AudioUnits/AUPublic/AUViewBase -i /Developer/Examples/CoreAudio/AudioUnits/AUPublic/AUCarbonViewBase -i /Developer/Examples/CoreAudio/PublicUtility -i /Developer/Examples/CoreAudio/AudioUnits/AUPublic/AUBase -i “/Users/drolland/juce/extras/audio plugins/demo/build/mac/build/Debug” -i “/Users/drolland/juce/extras/audio plugins/demo/build/mac/build/Debug/include” -i /Users/drolland/SDKs/vstsdk2.4 -i /developer/headers/vst -isysroot /Developer/SDKs/MacOSX10.5.sdk “/Users/drolland/juce/extras/audio plugins/demo/build/mac/…/…/…/wrapper/AU/juce_AU_Resources.r”

failed to find AUResources/AUResources.r
/Users/drolland/juce/extras/audio plugins/demo/build/mac/…/…/…/wrapper/AU/juce_AU_Resources.r:56: ### /Developer/Tools/Rez - SysError 0 during open of “AUResources.r”.
Fatal Error!
/Users/drolland/juce/extras/audio plugins/demo/build/mac/…/…/…/wrapper/AU/juce_AU_Resources.r:56: ### /Developer/Tools/Rez - Fatal Error, can’t recover.
AUResources.r: ### /Developer/Tools/Rez - Since errors occurred, /Users/drolland/juce/extras/audio plugins/demo/build/mac/build/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc’s resource fork was not written.

Denis.


#6

Hello,

I had this issue at some point but don’t remember exactly what the problem was… From raw memory I’d say it’s a search path thing, so check in the ‘wrapper’ folder to see if the AU files are indeed there and with good path (i.e. no in bold red).
Also, try to change the base SDK from 10.5/10.6 etc …

Hoep this helps some,

Salvator


#7

Yes, this doesn’t look like an include problem, just that your project isn’t pointing at the right files.


#8

Thx a lot, issue solved.

All path were correct but i found a solution.
I had to put the file AUResources.r in the directory wrapper/AU under the juce tree.


#9

+1

Never figured out the rhyme or reason to this … but every time I copy the example plugin project and compile it from another location this problem come up.

It’s been happening for a long time now.

I can’t remember how I used to fix it … and am unsure how to tackle it on the new system since now there are bigger issues when moving the example projects around (like the modules folder gets lost - and re-adding them to the new project is a major pain).

For now, I’m just compiling plugins by copying the demo plugin to another folder in the same directory. Works like a charm like that.


#10

again …

Now trying to run it on the new lion and xcode 4.3.

Had to save the AU files since they aren’t included in the new sdk (apparently?). But can’t link … see below.


#11

Oh yeah - solved this. Just need to remove AUResources.h from the rez step. You don’t actually need to rez that, but leaving it in there assure backward compatibility to 10.6.


#12

Sorry, I’m having this error and I am new to this. How do I do that exactly? Having no luck with google :frowning:


#13

I get this error all the time when my XCode is unable to actually locate the former /Developer/Extras/CoreAudio folder
Take a look on this link to ensure all the path are corrects (basically the header search path does matter)
http://www.rawmaterialsoftware.com/viewtopic.php?f=8&t=9546&start=15


#14

Just to update, the correct XCode path for placing the CoreAudio folder you downloaded is:

/Applications/Xcode.app/Contents/Developer/Extras