RTAS plugin builds fail with current tip using VS 2005 (?)


#1

I tried building the demo plugin today with Visual Studio 2005 (with today’s tip & introjucer)

The one option that worked for me was to enable “Build VST” only.
I couldn’t load an RTAS plugin build with “Build RTAS” only in the ProTools 9.0.2/debug build.

If I check both options, the resulting .dpm is smaller in size than the other two builds - and won’t load in VST hosts or RTAS.

All these were Debug builds with PT8.0 and VST2.4 SDKs, using a fresh build of the latest introjucer.

Has anything changed lately regarding the RTAS linker settings?


#2

Hmm - when loading the Release build of the plugin with VST & RTAS enabled simultaneously, I’ll get an additional error message:

“The program can’t start because MSVCP80.dll is missing from your computer”.

So it seems this problem is somehow related to the C++ redistributable? I do have the latest version installed.

We had some problems recently were 32 bit vst hosts couldn’t load ppmulator if they didn’t have this security update installed:
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26347

The weird thing is: Versions that were built before Microsoft did its update work fine everywhere. Only the one that was compiled after Microsoft’s security update was installed on the build/development machine wouldn’t work elsewhere unless that particular update was installed as well.

Is anyone else experiencing similar issues?


#3

It make sense in fact.

Just like when you update a .lib file, you need to update the DLL to match this new .lib


#4

It could be a problem with the DLL, but doing some checking, it looks like the new version isn’t correctly setting the calling convention for the RTAS files. Not sure if that’s related to what you’re seeing, but I’ll check in a fix for it shortly…


#5

@otristan
yes it does make sense, but we didn’t expect such a major compatibility issue to be triggered just be having regular security updates installed on the build machine.

Hope this info is still useful for others, it took as a while to figure out what’s suddenly going wrong - especially since you can still happily download the outdated version from microsoft’s download center.

but do you think the original problem from this post is related to this as well? It happens with current juce & the introjucer-generated demo plugin project, but doesn’t happend with our own plugins (with a ~1.5.2 juce and projects generated with CMake)

@jules
great, i’ll check that as soon as possible.


#6

The RTAS plugin loads builds and loads fine now when using the latest Introjucer, but I still have the same problem when building the current JuceDemoPlugin with JucePlugin_Build_VST and JucePlugin_Build_RTAS enabled.

It’ll load fine in ProTools, but both Ableton Live and the Juce Plugin Host fail to load the VST plugin.