RTAS problem: couldn't find MSVCP90.dll at Protools startup


#1

Hi everybody,

I have a problem regarding RTAS plugins development. Actually my audio plugin works perfectly as VST or AU on both win32 and macosx, but I am not able to make it work on Protools.

My plug compiles correctly, I move the .dpm and .rsr files to the correct location, but when I launch Protools (I was able to get a Protools 10 Dev version from Avid), when scanning my plug, it says that MSVCP90.dll is missing on my computer. However, I checked and I do have this dll… I tried on 2 different computers and get the same error.

I’m currently using the old Juce 1.53 API, but I spent some time compiling my plugin on the new 2.0 version and I have the exact same problem, so I think it’s not version-related.

Also, I tried to simply compile the audio plugin demo in /extras/ as a RTAS (by modifying the Introjucer configuration) and I’m getting the exact same problem at Protools startup. I’m well aware that the audio plugin demo project was not updated for a very long time…

Did anybody get the same kind of error?
(In the meantime I tried to make the RTAS work on MACOSX and it doesn’t even compile, but that’s another story :wink: )

Oh and by the way, the only other post about the MSVCP90 dll on the forum seems to be completely unrelated.

Thanks in advance for your time, guys!


#2

Hi,
Got the same error. Was fixed by setting “Generate Manifest” = YES.
In VS 2008 option could be found here: “Project Properties -> Linker -> Manifest File -> Generate Manifest”.