Running VST3 in FL Studio || Beginner


#1

I started learning juce a few weeks ago and I’ve made a basic synth plugin that runs fine in juce’s audio plugin host. I am trying to run it in FL Studio, but their plugin manager/scanner can’t recognize the .vst3 file. The following link from FL Studio (near the bottom of the page) says that FL on Windows works with VST3 plugins only if they have a .dll file extension.
https://www.image-line.com/support/flstudio_online_manual/html/basics_externalplugins.htm
If I understand correctly, VST3 plugins always have a .vst3 extension, so this doesn’t make any sense.

How have other people been able to get their VST3 plugins to work in FL?


When built i dont get .dll in builds folder
#2

Seems to be an error in their documentation. .vst3 files work fine for me. Make sure to put them in the right location. “Plugin search paths” are different for VST and VST3 and apparently you can’t add custom VST3 paths.


#3

Hi @NoamBendelac,
When I tried my vst3 plugin in FL for first time I have also some problems. Unfortunately I do not remember exactly a scenario, but now everything works. I think I had two problems:

  1. VST3 folder was not in “Plugin search paths”. The plugin was not on the list in plugin manager. Please check as @guten already mentioned.

  2. My plugin crashed first scan :stuck_out_tongue: The plugin was red on the list and on “Plugin” tab (near “Options” tab) status was “failed” or something like this.
    To fix this I had to:

  • change “Scan options” to “Rescan previously verified plugins”
  • attach a debuger
  • start scan again
  • then off course fix bug in plugin and one more time rescan plugins in FL

Then I marked my plugin as favourite (check a tick on the plugins list) to have it around in popup list in mixer.

Kindly regards,
Mateusz


#4

Thank you @guten and @mateusz. I now got my plugin to load, thanks to:

Looking at the FL documentation again, it seems they also tried to get that point across by listing “extra search paths in the plugin manager” only under VST 1 & 2, not 3.

Now the plugin manager lists my plugin, but leaves the “status” and “vendor” fields blank and leaves “effect/synth” as “?”. This is not a critical problem as the plugin itself runs, but I’m wondering if there is a way to fix this too. This doesn’t happen to 3rd party VST2’s, but it does happen to 3rd party VST3’s other than mine, so it could just be a problem with VST3 in FL.


#5

I have tried to reproduce such issue by messing in projucer. But with no luck. In project settings field “Plugin Manufacturer” cannot be blank. Also “Plugin VST3 Category” prevent to choose nothing.

Maybe try to check definitions of JucePlugin_Manufacturer and JucePlugin_IsSynth in AppConfig.h. If JucePlugin_Manufacturer correctly set, then try to add breakpoint in juce_VST3_Wrapper.cpp for constructor of JucePluginFactory (line 2669):

    JucePluginFactory()
        : factoryInfo (JucePlugin_Manufacturer, JucePlugin_ManufacturerWebsite,
                       JucePlugin_ManufacturerEmail, Vst::kDefaultFactoryFlags)
    {
    }

I was able to go into factoryInfo (VST SDK) and check the value of JucePlugin_Manufacturer.

Of course when I cleared value of JucePlugin_Manufacturer, FL do not show vendor name.

For “effect/synth” I have no idea. Maybe FL do not like some combination of effect types.
Does your plugin works in FL as effect or instrument?
Did you check this issue in there DAW (ex. Reaper)?


#6

Make sure to tick “Verify plugins” before running the search


I can't get the .dll of the VST3 plug-in
#7

Thanks! This worked.