Slider text boxes - can't enter text


#1

I am a noob on the Mac but I have recently compiled a plugin using Xcode. I am running 10.6. Everything works flawlessly except that I cannot enter text into any of the text boxes associated with the sliders in my plugin. The identical code works fine on the PC.

If I click on the text box, it looks like I am going to be able to enter text (i.e., the text gets highlighted), but keystrokes do nothing. I can, however, paste text in by right-clicking the mouse and selecting paste. That works fine and updates the slider appropriately.

I tried putting some breakpoints in my code, and even in the Slider class, but execution does not get there.

The sliders otherwise work fine, and they update the text box as you would expect.

I am using version 1_50 of Juce. I tried to git the tip and use that before I posted this, but it broke a few things that I didn’t want to dig in to right now. If it is at all relevant, the code that broke was the “getComponentProperty” and “setComponentProperty” methods of the component class. Looks like these were replaced with an improved interface. I do use these to store information about the sliders that are showing the problem described above…which may be related or a red herring.

Before I dig in and try to update to the tip – this seems like I must be missing something dead obvious as opposed to this being a bug in version 1_50 that nobody else has seen!

Can anyone help point me in the right direction?


#2

Can’t remember if this was a bug in 1.50 or not, so you should definitely try the tip.