[solved] AAX sign only on the "signing" PC?

Hey guys,

after a lot of trouble with avid and pace, i get the Pace signing tools.

I signed and verifed the Plugin sucessfull and on my Mac the Plugin works fine in the normal Pro Tools version (not the developer).

I tried another Mac and get the "*.aaxplugin is not a valid 64Bit Plugin" Error.

I created the certificates all by myself. Is that the Problem?


How can i fix that problem?

In this moment i install another Win pc and will try this on windows again. (I created the signing .p12 key on my mac for the windows build). After the test i will update the thread.


// Update

Windows works fine,

I also signed the Plugin now with a certificate from Apple (developer).

Same problem. On my mac everything is fine, on the other one he say's that the Plugin is not valid..


// Solved

I found the Problem,

i copyd all the time the plugin first from my mac to my windows pc and after that to the second mac, i didn't know what, but windows broken the file, compress the plugin first to a *.zip fixed the Problem



Just head-up for other developers.

I think Apple got 10.11.4 to break some codesign behavior.

(I see exact behavior with AAX...)


I’m getting this exact same issue and I have no clue why it happens. I can load the signed AAX on my system but not on another one. Does anybody have an idea of what’s going on?

Are you experiencing this on OS X? Also, How are you transferring the plugins?

Yes, on OS X. I’m compiling the code, signing the *.aaxplugin, put it inside the main distribution folder, rar compress it and server upload.

Hmmm. By chance, are you putting the file inside the main distribution folder by dragging and dropping the file? If this is the case, it’s possible that you are copying the file instead of moving the original- you can hold the command key while dragging the file to avoid this.

Tip for everybody distributing Mac OS X AAX plug-ins : don’t even copy and paste the files on Windows after the signing, or compress them in another format than ZIP. It messes up with the signing data, I had a hard time figuring out this with Spaceship Delay.

1 Like


I’m having the same problem as the original poster–signed AAX works on the machine I signed it on but not on another machine.

Somewhere (maybe in the Eden documentation) it’s written that you should zip the plugin with the -y option to preserve a symlink in the bundle, which I’m doing.

Is there something I need to be doing besides zipping the plug-in and copying the zipped file to my other computer? I don’t know anything about code signing. Do I have to use a distribution certificate? Do I have to share the plugin using TestFlight?

Thanks in advance for your help!