SOLVED: Missing file error trying to build AU with JUCE 7.0.2

I’m trying to build my plugin for the first time since updating to JUCE 7.0.2 (from 7.0) and the AU is failing with an error of:

‘AudioUnitSDK/AUMIDIBase.h’ file not found

/Users/stephen/Development/JUCE/modules/juce_audio_plugin_client/AU/AudioUnitSDK/MusicDeviceBase.h:8:10: 'AudioUnitSDK/AUMIDIBase.h' file not found

I deleted the JUCE Library folder and Build folder and relaunched my project from the Projucer, but the error still persists.

MacOS Mojave 10.14.6
XCode 10.3
JUCE 7.0.2
Projucer

EDIT: I guess I’m using the Dev tip from a few days ago. It seems the location of AUMIDIBase.h has been changed? Compared to release version of JUCE 7.0.2?

JUCE 7.0.2
juce_audio_plugin_client/AU/CoreAudioUtilityClasses/AUMIDIBase.h

develop
juce_audio_plugin_client/AU/AudioUnitSDK/AUMIDIBase.h

SOLVED:
It seems I needed to build the Projucer with the develop branch, and then use that to launch my project.

1 Like

Thank you for posting this. I had the exact same issue, although I was getting the error on a different file within the AudioUnitSDK, and your solution worked for me.

1 Like