[solved] TableBoxTutorial error: no member named getChildIterator

Hi folks, I’m trying to build the TableBox tutorial, and I’m getting an error
“No member named ‘getChildIterator’ in ‘juce::XmlElement’”

stemming from this line:
for (auto* columnXml : columnList->getChildIterator())

I’m using xcode 9 on OS X Mojave, JUCE 6. Not sure if I’m doing something wrong or if there is a bug in the tutorial now, does anyone know what’s going on here? I tried downloading both the Pip and the full zip contents.

thanks!

You might have an older version of JUCE on your system. Make sure to use JUCE from the develop branch on github when following the tutorials.

Ah ok, thanks!

Wouldn’t it make more sense though for the tutorials to be pinned to the release version? Not a big deal, but as a new user that is what I would expect usually from a project.

I will try out the develop version.
iain

In fairness, that functionality was added in January, so it is in the latest Version 6.0.8 from March.
@reuks comment was probably asking, if you are using a pre 6.0.8 version…
No need for develop, the latest release would do.

Ah fantastic, that got me on the right track. I had unknowingly left an old Juce lying around (6.04) and was using the new projucer but it was picking up 6.04 for building from a pip. It works now with 6.08.

thanks!

Is there a way to marked SOLVED? or does one just delete old solved questions?

All questions on that forum are solved :star_struck: (thus no marker is required).

I wish that was the case, but in general yes :wink:

1 Like

haha, ok!