Squished text


#1

Sometimes lines of multi-line text rendered by Juce get squished to fit optimally into the available area. Does anyone have any suggestions about how to disable this? I’d prefer text to never get squished but to simply be clipped if there’s not enough space available… I’ve thought about trying out the freetype module for Juce, but maybe, there’s an easier way…

I’m mainly working on iOS, but the behavior seems to the same on OSX and Windows as well…


#2

If you’re using a Label: juce::label::setMinimumHorizontalScale


#3

Is there a way to disable this behavior also in the FileBrowser component? It’d be nice if all the standard JUCE widgets would have a way of disabling the horizontal text scaling.