Suddenly can't build vst3 in Windows...|Error|MSB3073|The command copy /Y

I’m new to Juce but a few times now over the past few weeks I received this error that I can’t solve and I have to roll back to older saved work before the error started. It seems related to post-build processes (sorry if this is called something different). It seems that it stops writing the moduleinfo.json when vst3_helper.exe runs after build.

I’ve tried copying the .vst3 to the plugins folder but it won’t run without the moduleinfo.json which is present, only it’s blank… I also deleted the builds folder but that doesn’t work.

I’ve tried all Windows versions from 7.0.6 onwards but it still creates the error.

Thanks for taking a look.

The error:

Severity Code Description Project File Line Suppression State
Error MSB3073 The command copy /Y C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3\Abusive.dll C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3\Abusive.vst3\Contents\x86_64-win\Abusive.vst3
del /s /q C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3\Contents\moduleinfo.json
if not exist C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3\Contents\Resources mkdir C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3\Contents\Resources
C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3 Manifest Helper\juce_vst3_helper.exe -create -version 0.1.0 -path C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3 -output C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3\Contents\Resources\moduleinfo.json
:VCEnd exited with code -1073741819.
SaturationSoftClipper_VST3 C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.CppCommon.targets 161

It looks like the plugin is crashing when it is loaded to write the manifest. Other than the missing manifest, it looks like the rest of the plugin has been built successfully.

To debug this, you could manually copy the plugin from the build directory to the install directory, and then load it in the host of your choice while a debugger is attached.

Thanks for the reply… I’ve been using Reaper to debug with the Local Windows Debugger function in Visual Studio. I’ve also tried moving the vst3 into other directories to run in Reaper and Ableton but it seems like it doesn’t run without a proper manifest/modulinfo.json.

I’ve tried disabling the manifest generation by removing it from the post-build events but then it deletes the existing one. I don’t have a copy of the manifest before all of this started happening so without it, the daw doesn’t recognize the .vst3 and it doesn’t show up.

I will also mention that both times I got stuck like this was after incorporating 3rd party modules or introducing classes, but there really isn’t anything in the output or the errors to point me towards the source of the issue.

The moduleinfo.json is optional (but recommended!). Hosts should be able to load the plugin when the moduleinfo is not present.

I think it’s more likely that the plugin is crashing immediately when it is loaded, causing Reaper and other hosts to blacklist it.

You could try debugging with the JUCE AudioPluginHost. You can force the plugin to be scanned and loaded by dragging and dropping the plugin’s .vst3 folder onto the main window of the AudioPluginHost. Then, you should be able to step through the code and find out exactly what causes the crash.

I just tried dragging the .vst3 folder into AudioPluginHost and it crashed immediately…

I’mn not sure how helpful this is but here is the output:

2> 1 file(s) copied.
2>Deleted file - C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3\Abusive.vst3\Contents\Resources\moduleinfo.json
2>C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.CppCommon.targets(161,5): error MSB3073: The command “copy /Y “C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3\Abusive.dll” “C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3\Abusive.vst3\Contents\x86_64-win\Abusive.vst3”
2>C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.CppCommon.targets(161,5): error MSB3073: del /s /q “C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3\Contents\moduleinfo.json”
2>C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.CppCommon.targets(161,5): error MSB3073: if not exist “C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3\Contents\Resources” mkdir “C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3\Contents\Resources”
2>C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.CppCommon.targets(161,5): error MSB3073: “C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3 Manifest Helper\juce_vst3_helper.exe” -create -version “0.1.0” -path “C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3” -output “C:\Users\Jeremy\Desktop\SoftClipperTest\Builds\VisualStudio2022\x64\Debug\VST3/Abusive.vst3\Contents\Resources\moduleinfo.json”
2>C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.CppCommon.targets(161,5): error MSB3073: :VCEnd” exited with code -1073741819.
2>Done building project “SaturationSoftClipper_VST3.vcxproj” – FAILED.

If you make sure the debugger is attached before dragging the plugin into the host, you should be able to see the crash in the debugger and work out what’s going on.

I just had the exact same thing happen to me; turns out my plugin was crashing during scanning (due to some recent changes, but I could no longer build it because of the manifest generation step). More info:

I was able to attach the AudioPluginHost and get a call stack and some other info, which is infinitely more useful than what I was working with before.

I’ll see if I can’t sort this out, will check back either way.

Thanks for the help!

I encountered this too. I did a build check on my code and out of the blue it crashed like that.
It pointed to the
o:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.CppCommon.targets

line 160
<Exec Command="%(PostBuildEvent.Command)$(_BuildSuffix)" StdOutEncoding="%(PostBuildEvent.StdOutEncoding)" StdErrEncoding="%(PostBuildEvent.StdErrEncoding)" Condition="'%(PostBuildEvent.Command)' != ''"/>

Just rebuilding also hits that error.

Windows10 VS2022 + Projucer

I have no clue, but I could make it work thanks to GIT. Previous commit worked. So I copied last version files over the working commit and it built.

Then after a pull request it failed again.
Or build runs and after a minute with no changes it doesn’t.

Ended up recreating new project and moving my code.