Synth has no sound after upgrading to Projucer 7

When VS 2022 came out I upgraded immediately, and uninstalled VS 2019 after a few weeks after everything was working fine.

Note I always start my current project from VS 2022 directly, unless I need to add/delete a file via Projucer.

Now many months after I had to add a file to the project so I start Projucer which says there is an update. So I updated Projucer, add my new file, and at first forgot to look that “Selected exporter” was still set to “VS 2019”. Anyways the project loaded fine, but when I compiled I got a “Platform Toolset error 1.42”. It gave me an option to update, so I did to “1.43”. But when i compiled and ran there was no sound.

I then closed the project, and back in Projucer realized that it was still on VS 2019, so I added a new exporter, and selected “VS 2022” as “Selected exporter”, selected “Save and open in VS 2022”, compiled and tried to run, but now Reaper my DAW did not start as it used to, said can’t run “myplugin.vst3”. So in Visual Studio under the “VST3 Property” page, Debugging, Command I specified to run Reaper.

It now compiled, no errors, started Reaper where I as normal inserted the plugin in a track, pressed some keys but no sound at all! I checked other VST instruments and they play fine. Just to be sure my new file did not cause any problems, I deleted that too, I even backed up all my project source code files, and loaded from a week old backup, then recompiled, still not sound!

So something is obviously wrong, perhaps Platform Build Tool 1.42?

I use these tools intensively every day and have not experienced anything like you describe, I recommend to search in other directions.

Switched to 2022 last year when it came out, very happy with it.

Have you tried to build it as standalone? There are quite some variables in your build and run setup. Try to zoom in on the problem by excluding factors such as your debug settings and Reaper.

I’ve happy with VS 2022 too. My problem just came today after upgrading Projucer.

I just rebuilt Projucer with the latest develop, saved a plugin project, built that and checked the Vst 3 in Reaper. All well here.

I first downloaded and reinstalled Projucer 6.16, then started VS 2019, tried to compile but again said it could not find Build Tools 1.42. After re-targeting to 1.43 and compiling still sound.

I then installed Build Tools 1.42, recompiled, and now I have my sound back again! Now I’ll try to upgrade to Projucer 7 again and see what happens.

Nope! No sound after again upgrading to Projucer 7, either exporter VS 2019 or VS 2022 (keep noting both actually starting in VS 2022, as I no longer have VS 2019 installed) Build Tools 1.42 or Build Tools 1.43!

Downgraded again to Projucer 6.16, compiled again using exporter VS 2019 with Build Toolset 1.42 and bam sound is back on! Then tried using exporter VS 2022 with Build Toolset 1.43 and now that also works with sound.

So problem for me is Projucer 7. I should mention that besides no sound, there is also one graphics element, a graph of static waveform used to making sound, that does not show using Projucer 7.

Does the plugin still use the projucer channel definitions like { 2, 2 } ?

Nothing have changed on my code. Do you mean if a Projucer setting changed?

Have you tried building the plugin as a standalone and trying to bypass Reaper and your debugging setup?

Maybe this simplified output channel feature is broken in projucer. I remember there was also a problem with that a few years back.
I would strongly recommend defining the input and output channels in the code anyway if you didn’t already. This may fix the problem without waiting for a projucer fix.

Maybe this simplified output channel feature is broken in projucer. I remember there was also a problem with that a few years back.

This may fix the problem without waiting for a projucer fix.

Don’t post such nonsense if you apparently have not even tried anything yourself regarding this post.

I’m wasting my time here. Lots of success

I am defining the output in the code.

1 Like


I already noticed your rude comment in another thread. This forum used to be a place where people speak respectfully to each other. This is not the KVR forum!

Please leave it if it’s wasted time for you. You don’t have to do this.


I would try to debug and find out if your plugins processBlock() method is called and if it gets the expected input and output channels.

I will, thank you.

I now also realize that I can no longer set a valid debug break point on files changed after trying to upgrade to Projucer 7 and selecting VS 2022, and that is even after I downgrade to Projucer 6.16 but still selecting VS2022. It says “The breakpoint will currently not be hit. No symbols have been loaded for this document”.

When running in Debug mode, and check Debug → Windows - > Modules → Mutineer.vst3, I see that path is still C:\JUCE\Mutineer\Builds\VisualStudio2019\x64\Debug\VST3, so it’s looking for an old version of the PDB symbol file. I am know trying to figure out how to change that so it instead loads the PDB file in the VisualStudio2022 folder.

So in other words; Even though I have added Visual Studio 2022 as an exporter, and checked that the “Target Project Folder” is “Builds/VisualStudio2022”, and have “Selected exporter” as “Visual Studio 2022”, Visual Studio compiles files in the correct VS2022 folder, but when I check the symbols file it still think it resides in the VS2019 folder.

This is the first time in the four years I started using Projucer, and upgrading every time a new version came out, that I had these problem.

I found out what I was doing wrong, at least for my debug problem! In Reaper I forgot to change path to look for VST files from “C:\JUCE\Mutineer\Builds\VisualStudio2019\x64\Debug\VST3” to “C:\JUCE\Mutineer\Builds\VisualStudio2022\x64\Debug\VST3” - OUCH!

Most likely it will also take care of the missing sound problem after upgrading to Projucer 7 - A bit embarrassing. This I will test a bit later and post my result, but I apologize for wasting everybody’s time.

1 Like