Text-rendering bug windows/ttf

I’m using custom font rubik regular (Google Fonts)

in combination with a TextButton.

After the “i” was once was drawn as a compressed version, it will always draw “A” instead, when the text is not compressed. Looks like there is an bug in the text-drawing routines.


Screenshot 2021-03-04 at 12.19.43


Screenshot 2021-03-04 at 12.19.59

Strangely enough I can’t reproduce this in another project. Does anybody has ideas what the problem might be? I suspect the glyph-cache but i can’t figure it out yet.

PS: Interesting, it also effects the “.” so both letters with a small dot “i” and “.” (which of course could be coincidence)

While there might be bugs in the font rendering, I’d try to fix the font instead. Unless this happens for all fonts. Maybe just loading this font into FontForge and exporting again will solve the issue.

Thank you! I tried to generate it again, but the result was actually worse. I finally found an older version of the font in my repository which worked. I guess it was somehow messed up during the development. (This whole font rendering-thing is a mystery)