Tip compilation issue


#1

Hi Jules

In Mac, I’m getting this errors when compiling:


#2

I’m using base SDK = 10.5 , when changing to 10.7 it does compile.

Update: 10.6 also works well.


#3

Sigh… Yes, I know, it was added in 10.6. I guess I’ll add some #ifs around it.

Are you still using the 10.5 base SDK because you need to? If you can use a new SDK with an older compatibility setting, that’s definitely a better way to do things.


#4

Thanks Jules

This was the only way I found (base SDK = 10.5) to make the AU plug-in run in Leopard.

I don’t have a machine available for testing right now, but if I recall correctly using base SDK 10.6 + compatibility = 10.5 did not work when I tried it.


#5

Well, try it again now and it should be ok.


#6

I’m still getting this error:


#7

Ok, I reluctantly dusted-off Xcode 3 and tried it myself - try it again now!


#8

Hi,

I’m getting some compilation issue with gcc 4.0 on OSX regarding ContentComponent accessing private data in TreeViewItem.

Thanks,


#9

Then use GCC4.2 or later.

I mean, honestly, I do my best to support these older systems, but using gcc4.0 is just silly.


#10

Now it works great.

Thank you Jules for the quick response