So it seems that the marketing decision to rename Tracktion into Waveform broke its detection.
Would be nice to add it:
if (hostFilename.containsIgnoreCase (“Waveform”)) return TracktionGeneric;
(or something more implicit than Waveform maybe?).
Our product used this to Whitelist hosts we’ve seen that reports recording state properly.
Would be nice to keep it as TracktionGeneric and add isWaveform() with TracktionGeneric but that’s for the JUCErs to decide.
Sorry, had forgotten about this… will be on develop shortly.