Trouble Using AudioPluginHost

I cannot seem to launch the AudioPluginHost as I have been able to in the past. I’ve tried doing this with a new, totally unmodified Audio Plugin project, so I don’t believe it has to do with my own code.

Using the lastest version of JUCE (7.0.4), I’ve compiled AudioPluginHost and set it to the debugging target of the solution in Visual Studio 2022. When I attempt to launch the AudioPluginHost/plugin with the Local Windows Debugger, an exception is thrown in the JUCE DSound thread by ArrayBase::end() (read access violation, this was nullptr).

When I try to launch the AudioPluginHost by itself in Windows, the program is unresponsive.

I’m not quite sure how to interpret this error or remedy the situation.

In case anybody is wondering, I installed AudioPluginHost 7.0.2 and it ran without issue, so I’m having the VS solutions target it for debugging currently. Hopefully this issue will resolve itself in future versions.

I have switched (from Juce 6) to Juce 7.0.4 today
and the first thing I tried was building the AudioPluginTool.
(However, using Visual Studio 2019 rather than 2022).
The AudioPluginTool was built without problems and it runs
(as a standalone app started from windows) without problems.
I have not yet tried to start it as a debugging target.

1 Like

I’m not able to repro here. The AudioPluginHost opens and runs, using both WASAPI and DirectSound.

Is it possible that the crash was in a plugin that was loaded by the 7.0.4 build, and that you changed some aspect of the default project (cleared it, rebuilt/modified a plugin) when switching back to 7.0.2?

The default project was created with JUCE 7.0.4, which crashed in the AudioPluginHost built using 7.0.4, but ran just fine using the AudioPluginHost built with 7.0.2. I hope this helps!

@reuk Able to identify the issue as AudioPluginHost.exe attempting to load the previous .filtergraph settings, as deleting this file took care of the issue, but must subsequently be deleted again before attempting to launch again, lest it crash trying to open the new one it created. Anybody else experiencing this? A little bit annoying to keep setting up the plugin/connections after rebuilding each time. I’m on 7.0.5 by the way.

At the moment it’s not clear what the problem could be. Please could you provide the following:

  • A copy of the filtergraph file that causes the crash
  • A full stack trace at the point of the crash
  • Any information about your system that might be relevant (OS version, connected external audio hardware/interfaces)

AudioPluginHost_StackTrace.txt (3.0 KB)

I’ve attached the stack trace as a .txt file, but I’m not able to attached the .filtergraph file to forum posts - do you have an email I can send it to or another way for me to get that file to you?

As much relevant system information I can think of:

-Windows 10 Home
-JUCE 7.0.5
-Crashes on my ancient UX1 interface, and through the computer without an interface.
-Intel i5

Hope this helps!

-Working in Visual Studio 2022

I think you can zip it, IIRC zips are allowed

I’ve had a bit of a look into this, and so far I can’t work out exactly what’s going wrong.

What if you change the file extension to .txt first? Otherwise, you can send it to support (at) juce (dot) com.

In your first post, you said you get a crash on a DSound thread. Do you still get a crash if you use a different audio device type (e.g. Windows Audio)?

Also, the AudioProcessorGraph code has changed quite a bit since 7.0.5, so could you try out 7.0.7 and see whether you get the same crashes there?