Trouble with Faust->JUCE->VST3

Boils down to some files in the VST2/3 SDK.

aeffect.h and aeffectx.h

which are not found in the path. Note that the JUCE options to set paths etc. have changed since most of the online materials I have found were published. It is no longer possible to set a VST3 SDK path. Although I read that VST3 SDK is included in JUCE now I downloaded and installed it anyway.

I found files audioeffect.h and audioeffectx.h and tried copying those to the similarly named files the code is looking for, modifying the juce_VST_wrapper.cpp file to point directly at those using the full path, but it does not appear to be the solution.

I tried following this but as I said, the UI no longer offers some of these options.

I’m using the Faust IDE and exporting the code as juce/plug-in.
Projucer is 6.0.8.
Using VS2019.

I’m able to successfully build the Plugin examples from JUCE, e.g. the Surround Sound VST3 works fine without any fiddling around.

I think I figured it out. You have to edit the .jucer file which is exported by Faust.

#1 set buildVST=“0”, buildVST3=“1”
#2 change buildVST in “pluginFormats” section to buildVST3.
#3 add JUCE_VST3_CAN_REPLACE_VST2=“0” to the “JUCEOPTIONS” block near the bottom.

I guess I can get away with this as I did not previously create nor do I care about VST2 plugins.