Troubles Building Demo Projects


#1

I am brand new to JUCE and what C++ experience I have is years old, and I could use a little help getting off the ground. I tried building the demo in the juce/extras/JuceDemo/Builds folder, but I get this error:

||=== Juce Demo, Debug ===|
C:\Users\to_the_sun\Documents\GitHub\JUCE\modules\juce_audio_basics\buffers\juce_FloatVectorOperations.cpp||In function ‘void juce::FloatVectorHelpers::mmEmpty()’:expressionless:
C:\Users\to_the_sun\Documents\GitHub\JUCE\modules\juce_audio_basics\buffers\juce_FloatVectorOperations.cpp|50|internal compiler error: in ix86_compute_frame_layout, at config/i386/i386.c:8843|
||=== Build finished: 1 errors, 0 warnings (0 minutes, 5 seconds) ===|

which points out an empty line as where the problem is, confounding me. I also tried building the Introjucer and get this result:

||=== The Introjucer, Debug ===|
C:\Users\to_the_sun\Documents\GitHub\JUCE\extras\Introjucer\Source\ComponentEditor\components…\JuceLibraryCode\modules\juce_graphics…\modules\juce_graphics\colour…\images…\contexts…\geometry…\placement\juce_Justification.h|28|fatal error: …/geometry/juce_Rectangle.h: No such file or directory|
||=== Build finished: 1 errors, 0 warnings (0 minutes, 1 seconds) ===|

I tried changing the line it was complaining about,
#include "…/geometry/juce_Rectangle.h"
to the exact location of the file to include which alleviated that error but caused others. I am using Code::Blocks because that’s what I already had on my computer, but just downloaded Visual Studio to see if that might work instead. In any case I’m wondering if I have to do anything before trying to build, like linking libraries etc? With JUCE I was kind of under the impression that that wasn’t necessary, but like I said I’m brand new to this and could really just use some very basic instruction here on setting up a project to begin working on… Any help?


#2

I think the tell-tale phrase in your error message is where it says “internal compiler error”. I’ve no idea what version of gcc you’re using, but I think updating to the very latest would be a good start!


#3

I’ve seen a similar thing in gcc4.8, but not sure if related:

../sequencer/src/jack.C:137:61: internal compiler error: Segmentation fault ++notes_on[ port ][ e->channel() ][ e->note() ]; ^
Quite funny that a compiler crashes… :lol:


#4

I’m pretty sure I have the latest version (MinGW is what came with my original CodeBlocks download), but to be sure I downloaded it again from here

Still not working tho. And what about the Introjucer build? There’s no complaint of an internal compiler error there.
Let me make sure I’m going about this correctly: to build the Introjucer say, all I should have to do is open up the Introjucer.cbp file from the CodeBlocks folder and then select Build (Ctrl+F9), right? Or am I missing something?

Thanks for your help


#5

I seem to remember that mingw had some kind of stupid problem with maximum filename lengths - if you have a deeply-nested include path like the one above that goes over some pathetic 256-character limit , the compiler craps out and can’t find it. Thought they’d fixed that in more recent versions, but I could be wrong. The only workaround would be to move the juce tree to a root folder to make the path shorter.

Stuff like this is why I’d never recommend Code::Blocks unless you’re a masochist or have a technical reason to use it.