Stuck before I've started


#1

ok so I’ve downloaded JUCE and also code::blocks. I’ve opened the juce demo app and done a right click and tried to build. At this point I get the following message

“Juce Demo App - Debug” uses an invalid compiler. Skipping…
“Juce Demo App - Release” uses an invalid compiler. Skipping…
Nothing to be done.

and nothing happens. I have tried two different compilers from the list. how do I know what I have? basically I am stuck at the very first point…;

help appreciated.


#2

Use VC2008.

http://www.microsoft.com/express/download/

HTH


#3

oh really do I have to…(sigh) oh well that is kind of what I was thinking of using next. been trying to un-microsoft my life. still if it works…


#4

We really ought to have a sticky: If you’re using Windows, save yourself from pain and use Visual C++.

Heck, jules is more patient than I; if it were my library, I would simply refuse to provide any support for anything else! [on windows, there really is no need for anything else!]

[apart from anything else… oohh this argument always is unstoppable from me! If Windows is the OS, you may as well consider Visual C++ Express as a built-in (albeit one you have to download) and have done with it.]


#5

as far as Codeblocks goes, i think yo uonly installed GCC (ANSI C compiler) and missed the G++ (C++ compiler) or didn’t install a compiler at all, you need to install MINGW and tell Codeblocks where it’s at.