UB Audio Unit not recognized on PPC


#1

Hello,

I’m building an Audio Unit for Mac Intel and PPC.

The AU works on Mac Intel but is not recognized on PPC although I compiled in Universal Binary. I also tried to force the compilation target to PPC.

I also compiled an application based on the plugin and it works on both Mac Intel and PPC.

My development platform is Mac Intel. I’m using the tip.

Does anybody have an idea ?

Thanks


#2

I’ve been having trouble with this kind of thing for a long time. Assuming you’re using later than 10.3. Try ensuring that you’re using only the 10.4 SDK and make sure that any MACOSX_DEPLOYMENT_TARGET_ppc setting is removed form the project/target. Some of the Juce projects had this included and it worked sometime ago but I can’t seem to get it to now using the tip. Keeping to 10.4 and later seems safe.

Unfortunately the old 550 G4 PB I was testing on now won’t boot… that was my last working Mac OS 9 machine!


#3

BTW this is related to this thread:

http://www.rawmaterialsoftware.com/juceforum/viewtopic.php?t=4055

I finally got my old G4 550 PPC back up and it successfully runs a UB app built in Xcode 3.1.2 (on 10.5) using the static libs (rather than the amalgamated version)

My previous problem was here:

http://www.rawmaterialsoftware.com/juceforum/viewtopic.php?t=3379

MACOSX_DEPLOYMENT_TARGET_ppc set to 10.3 seemed to be the culprit


#4

Hi Martin,

Thank you very much for your help. It works now. And my apologize for giving you a feedback so late. :oops: