PCC AU juce demo. Xcode 2.5


#1

I`ll try to build JuceDemo AU for ppc(or universal).
My system:
Leopard 10.5.1
Xcode2.5
SDK 10.4u
juce 1.45

It builds, but does not recognized as AU by Rax 1.2.3(ppc AU host).
Rax works fine with 3-rd party pcc plug-ins.
I check info.plist data, component package. All looks health.

Bug from hxxp://www.rawmaterialsoftware.com/juceforum/viewtopic.php?t=2588(hxxp://lists.apple.com/archives/coreaudio-api/2007/Nov/msg00040.html )fixed.
VST ppc version works good(with juce host builds to ppc).
Intel build works fine.
Any ideas?
Thanks.

P.S. Sorry for pure english.


#2

Did you see this:
http://www.rawmaterialsoftware.com/juceforum/viewtopic.php?t=2123

…I think you mean “poor” english! :wink:


#3

Thanks, but i know about this bug.
I use Xcode2.5 with CoreAudio SDK 1.4.4(with fixed defines).

I tried to use 1.3.4 SDK(+ AUResources.r fixing) - no results.

Hm…
Apple`s AU demos with PPC building do not work too.


#4

I`m download last auval(1.1.1b11)
It is not recognize all Juce AUints as plugins(Intel versions too).
But AULab work with them fine.
Strange…


#5

I had something similar where aulab, auval, and every other host worked fine with my plugins, but Logic wouldn’t recognise them. I never quite got to the bottom of what was going on, but it miraculously all started working again. I suspect that the apple component manager might be flaky sometimes, and just refuses to recognise certain files as components.


#6

Maybe.
I`ll try to build it on Tiger.
And some magic of course. Black cat go out! :twisted:
:slight_smile: