Unable to build projects in Xcode (undeclared AUv3 identifiers)


#1

Hello all,
I seem unable to build projects in Xcode. When trying to build the included Plugin Host, per example, I get the following errors:
https://db.tt/SD4ZpQOn

It seems to be an issue with undefined variables for the AU v3 plugin type, or the conditionals surrounding them passing when they shouldn’t. I’m uncertain as to how to resolve the issue.
I’m running the latest Projucer with Xcode Version 6.0.1 (6A317) on Mac OS X Yosemite 10.10.5.
Any potential solutions or support resources would be appreciated.


#2

This was fixed recently. Please update JUCE from github.


#3

Hmm, I pulled the latest commit on the Github, and tried to rebuild; same issues are occurring. I deleted the prior Xcode project then saved in Projucer and tried to rebuild again; no dice. Is there anything else I need to do for setup?


#4

Which target SDK and base SDK are you using? Which XCode version are you using?


#5

I’m using Xcode Version 6.0.1 (6A317). As for the SDKs, I haven’t done much software dev in conjunction with an IDE; how can I determine those? I’m getting these errors in trying to build the included ‘audio plugin host’, so I’d presumed targets would be set up preemptively.


#6

Hey, I upgraded to OS X El Capitan (10.11.4) and freshly installed Xcode Version 7.3.1 (7D1014) as well as the latest JUCE on the git from scratch; one or all of those steps has fixed my issue, things are compiling fine now. Sorry I can’t provide a more specific solution as to what helped!