Update Projucer warnings. Dont understand why / how

Hey,

So when I run the Projucer I get this:

which seems ok to me as I installed Juce 6.0.5 and it all matches

but when I went into my JuceHeader.h file it complains with this:


Which doesnt make sense to me!

As a side note, Im a bit worried about updating Juce to the latest 6.0.7 as I installed Juce in my system and the Projucer wants to update it via a download location.

What is the correct method to update a system install of juce and to also obtain the correct Projucer version for it?

Seems the Projucer doesn’t like you to downgrade.
The latest Projucer is 6.0.7 and it seems you had that at some point and saved the project.

Test with which Projucer to see where the Projucer you are running is located. I guess it is a symlink pointing to the outdated version.

To update I simply cd into the JUCE directory, call git pull origin master or the branch you are using. If you want to switch to develop, call git checkout develop first.

Then use make to build Projucer:

cd extras/Projucer/Builds/LinuxMakeFile
make -j 8

Hope that helps

Hi,

My Projucer is just in a special path folder I created.

My juce install has no “extras” folder. I know it does if I download the zip version but I didnt do it like that. It lives in the root system folder via JUCE/install

That is strange. Can you do a git status to see if it was locally deleted?
Anyway, I would recommend to clone fresh from github. It should be identical afaik:

git clone git@github.com:JUCE-framework/JUCE.git
// or if you prefer https:
git clone https://github.com/JUCE-framework/JUCE.git

This is the install method I used:

I never used git.

If I use your method is that going to basically be the equivalent of downloading a zip?

I cloned a fresh JUCE 6.0.7 and build Projucer 6.0.7
Then I linked to the fresh install folders for a brand new project
everything builds fine so far BUT im still getting the same warnings in JuceHeader.h
My projucer states that it is version 6.0.7 too.
I guess ill just have to ignore it

The first line it logs is the version the Projucer was built with. In your screenshot it says 6.0.5. Does it show 6.0.7 now after building the new one? Otherwise you have an old binary in your search path that is found instead. Hence the check using which Projucer

“which Projucer” returns nothing

But when I run it, it now says version 6.0.7 yes

I see, so you don’t have Projucer in the search path but the . is. Uncommon setup, I thought putting the . in the PATH was not advised, but maybe advise has changed… I am not a full time admin :wink:

In that case yes you are running the right one.

I cannot comment, if ignoring the warning is ok, somebody else should comment.

Good luck