VST/AU builds fail after upgrading to Xcode 15

I believe we’re in an “Apple broke…” scenario. I went to the store and bought a fresh new MacBook Air, updated it to Sonoma as soon as I got home, then built my entire Git repo in a non ~/Documents folder and it worked fine. (As referenced above.) I had to take the other machine in for repair, so I had to stop my experiments, but when I get it back (Monday, most likely) I will attempt rebuilding my Git repo in the same location as the new machine and hopefully be back in business.

But my general take is still that if your Git repo or workspace is in ~/Documents, pay close attention to the iCloud settings when updating to Sonoma.

See thats the weirdest bit for me, my juce projects are in my user folder (/Users/myName) and not the cloud synced folder. I’m not sure if this folder is also synced to icloud and it could be the root of all my issues. I’m gonna end up testing that now actually

EDIT: That did not fix it, i moved my project to an external drive, cleaned the build folder and retried a build with the same cycle error as my other juce projects. Projucer also refused to build

that iCloud Documents folder is a certified PITA. We used to do a lot inside the Documents folder at runtime, but since Apple started leading people towards the virtual Documents folder we’ve had to move everything to ~/Library/Application Support. Maybe that’s always been the “correct” approach, but Documents felt like it was there for that reason.

This is a terrible state of affairs … but one stupid question: did you check that there aren’t any .DS_Store files being inadvertently spewed into your .app bundle folder while you Finder around to see whats going on? Because this happens, all the time, and is at the point that I have this command on muscle-memory for just this scenario …
$ find ~/Documents/JUCE_Projects/ -name “*.DS_Store” -exec rm ;

I also cannot build on Xcode 15 using the CMAKE exporter. The problem persists with the current develop branch of JUCE. MacOS version is Ventura 13.6, will try Sonoma later
One of the vst3 post build steps fails with:

The bundle “MyPluginName” couldn’t be loaded.Command PhaseScriptExecution failed with a nonzero exit code

The command that’s failing is:

juce_vst3_helper -create -version… etc

Same issue here.
I cannot launch build VST/AU since I get the “cycle inside AU produce unreliable results” issue.
Any news regarding a new version of JUCE with a fix will be released ?

I got this issue too after updating my Mac to Sonoma and updated Xcode. The project worked fine before the update. I tried cloning the latest juce commits on GitHub and that didn’t work either. Anyone know why this might be the case.

Note that you need to clone Develop branch and not Master. Then, delete your build folders.

There are news? I also get this error:

Command PhaseScriptExecution failed with a nonzero exit code

I think i’ve tried this about 4 times now with no success. I’ve build the develop branch, cleared out literally everything other than my assets and the .projucer file, reopened the project, resaved and then opened in xcode all to be greeted with the same error (build failed, cycle etc etc.)

I’m pretty confused now ngl

You did not mention that you rebuild Projucer from the develop branch, did you do that?

It was the first thing I said I did….

Sorry, it’s been a long day. I am out of ideas other then try to unplug the power for 5 seconds then restart… :woozy_face:

Hey folks…Dev here who migrated from Mac OS X 14 to 15, now running into “cycle build” issues on Projucer files that “just worked” before the OS upgrade. Fresh OS install of 15 is not an option for me.

I am able to build by manually removing the “Installation Build Products Location” from the Xcode projects generated by Projucer, but obviously we want Projucer to be the source of truth.

Can I do this with 7.0.7?

For anyone who is still fighting with this issue, after upgrading to Xcode beta 15.1 I am able to build fine on both master and develop branches.

1 Like

I just upgraded to 15.1 beta and I’m still getting the same cycle build error. I even wiped everything out and started fresh from the juce GitHub repo.

For anyone still experiencing issues, are you experiencing these issues with any of the provided projects such as the Projucer and DemoRunner or only your own projects? If you are experiencing the issue with projects such as the Projucer can you try running the following from a terminal and see if you still experience the same issue?

git clone https://github.com/juce-framework/JUCE --branch develop --depth 1  
xcodebuild -project ./JUCE/extras/Projucer/Builds/MacOSX/Projucer.xcodeproj

If that works try running

open ./JUCE/extras/Projucer/Builds/MacOSX/Projucer.xcodeproj

This should open the Projucer project in Xcode, type CMD+B to trigger the build in the UI.



Projuicer works fine for me and so do as DemoRunner and AudioPluginHost. It only fails to build for my own projects even after creating a new blank basic plugin

To be clear now you’ve built the Projucer can you open that new version of the Projucer and create a new project with it? (note please close any versions of the Projucer you may already have open before trying to run the new version)

You could double check you have the right versions of the Projucer open by going to the menu and selecting Projucer >> About Projucer and confirming the JUCE version and build date.