VST debugging with Cubase


#1

Hello all,

Having a problem with a VST plugin in Cubase 5 I can’t figure out!

The plugin is recognised by Cubase but crashes as soon as you try to add it as an insert. I am debugging with Visual Studio 2010, and the problem appears to be at:

juce_AudioProcessor.cpp Ln 239:

const ScopedLock sl (callbackLock);

No error messages are given; at that point I can no longer step through and Cubase crashes.

I’m relatively new to this so I’m sorry if I’m not giving good descriptions or enough information.

Any ideas?

Mike


#2

Although I’m not sure with Cubase but I would guess it would be difficult to debug in a copy-protected app (as using a debugger is one tool used by crackerz). For example, it is impossible to debug in the full version of MaxMSP (which is PACE-protected). Have you tried debugging in something else first to see if it’s a general problem with your plugin rather than something Cubase-specific? You can debug in Reaper for example. Of course there’s also Juce’s own plugin host app in /extras.


#3

The plugin functions perfectly in the JUCE PluginHost - I’ve been testing with it because it’s so much quicker.

I’ll give Reaper a go!

Mike


#4

never had problems with debugging plugins with Cubase (Hosts-companies that prohibit the using of a debugger, are just silly, because they make it difficult find issues which are only happen in the interaction between plugins and host)

Mike: Look at the output-log Windows, there must be something, i bet its a access violation
Is callbackLock correctly initialized?

Do you have the same problem with the Demo-Plugin/fresh generated IntroJucer project?


#5

Thank you both for your replies.

Problem was the FFTW library, don’t know how or why but tried stripping it out and replacing it with an ALGLIB FFT and Cubase loads and displays the plug-in fine, maybe it didn’t like using the external .lib file?

Thanks again!

Mike