VST/VST3 can't be loaded in other machine

In my windows PC, my plugin works without problem.
But in other PC, it fails to be loaded.
I tried Ableton, Reaper, and Studio One, but they didn’t recognize my plugin.
I tried to make new “Audio Plug-In” project, but it wasn’t recognized in other computers either.

Is there anyone who have been encountered the same thing?
Thanks!
Environment::Windows7, Visual Studio2017, latest JUCE(5.4.3).

You’re building on a Win 7 machine? Maybe that’s the problem. What version of Windows are the other ones you’ve tested on running? You should generally build on a newer OS and target older OS versions if you need to support them, so that your code is compatible with newer OS versions. If you only have an older WinSDK, then you might see a problem like this on newer OS versions. Just a thought.

1 Like

Probably missing Microsoft C++ runtime DLLs on the other machines. Rebuild the plugin with the runtime statically linked. (It’s an option in Projucer in the project exporter options.)

Building on Windows 7 works fine to produce plugins that work on higher versions of Windows.

2 Likes

Thanks!
I switched Projucer’s “Runtime Library” as “Use static runtime”.
Then, DAWs recognized my plugin at other PC(windows7).
But GUI won’t show up…
I also think it’s due to lack of runtime.
Do you have any idea about the runtime which affect GUI? …Or, how can I include all runtimes used in my VST .dll?

Another reason can be you built a debug version instead of a release version. That’ll run on your development machine but possible not on others… happened to me a couple of times …

1 Like

If the plugin is successfully scanned by the host, it likely isn’t a runtime issue anymore but more likely some bug or mistake in the plugin’s code. Does the plugin need some external files like images or audio or settings in order to run?

Can you confirm if the plugin is completely inoperational or is it just about the GUI not showing up?

1 Like

Thank you for you three to answer my question!
@tomto66 I’m sorry, it’s release version…
@Xenakios Plugin can be loaded, but when I try to show editor
Ableton:“Serious program error has occured…” dialog show up, and Ableton shut down.
Reaper:only crash
Studio One: (No editor show buttons),
Renoise(new!):“ouch. The VST plugin ‘yourPlugin’ crashed in VST event/function : ‘Dispatch’. Thread’GUI’!..(report the error to the developer and Renoise isn’t the problem… blah blah)” dialog show up.

Each DAW can control plugin’s Parameter by its interface without plugin’s GUI.
The strange thing is, my plugin’s GUI can show up without any problem on my PC in all DAWs.

Does the plugin need some external files like images or audio or settings in order to run?

Yes, it uses some images, but they are all used properly…I think :stuck_out_tongue:

Anyway, I’ll reinvestigate my source code carefully!

BTW, isn’t it interesting how each DAW respond to bad VST?:grin:
I’m considering if I should preserve this broken VST for testing other DAWs.
Renoise’s dialog text is very good I think!

If your plugin uses images, how are those distributed? Did you add the images as binary objects in Projucer? If so you don’t need to worry about them. If not … better make sure those images are where your plugin expects them to be… (or even better, add them as binary objects).

Like @Xenakios hinted, what you are describing is most likely file-related!

Did you add the images as binary objects in Projucer?

Yes. Sorry that I didn’t make it clear enough!

I made a new and clean windows7 PC (and installed Visual Studio2017 and JUCE), copy my plugin’s project folder, make project from Projucer, and rebuild.
The result is, the plugin, which is builded from clean Win7 PC, worked on any other PC at any DAW!
So the problem…

  • isn’t external files.

  • isn’t runtime(I builded “Use static runtime”)

  • isn’t debug version(I builded release version)

Something’s wrong with my working PC :thinking:
I know it’s very difficult to answer because No one knows the environment of my woking PC, but any suggestion/comment will much be appreciated!
If you have encoutered the same/similar problems, please tell me.
Thanks.

Did you check with the dependencywalker?
Do you by chance set some hilarious editor sizes, that assume a high resolution screen, or did you anything else non-standard?

Just more shots in the dark…

1 Like

[Solved!!]
I’m really sorry that I was too silly to try to make a file to non-exist directory at my Component Class!
It’s only for the debug, but I forgot to remove the code…
My plugin finally worked on other PCs.

Big thank you for the four who made suggestions!

@daniel I didn’t know dependencywalker. It’s a fantastic tool!