Why does the arpeggiator demo install two audio units?


#1

When I run the arpeggiator demo project, two audio units get installed:

aufx Arpg ROLI  -  ROLI Ltd.: Arpeggiator
JUCE v4.2.1
aumi Arpg ROLI  -  ROLI Ltd.: Arpeggiator

I’m really only interested in aumi, but I can’t figure out how to turn off the aufx. I’ve tried just selecting ‘Build AudioUnit’ and ‘Plugin is a midi effect plugin.’

When I build Apple’s AudioUnitMidiProcessorExample it produces only the single plug-in.

aumi aump Demo  -  Apple Sample Code: AUMidiPassThru (MIDIProcessor AU)

#2

This is fixed now. See this thread for further info.