Windows: Missing Module Paths in Project checked out from Git

windows

#1

While I’m usually developing under macOS, I want to compile a project I’m working on under Windows. Creating a new project under Windows works,
however when saving the project I cloned from Git in the Projucer, I get the following error:
33

I’ve committed everything except for the Builds and JuceLibraryCode directories.

What could cause this error? My modules are properly set, otherwise the new project wouldn’t work, right?


#2

Have you set the global modules path for Windows? There’s a drop-down in the global paths menu that you can use to set the paths for other OS’s:


#3

Yes I have. These are my settings:


#4

OK. Which module(s) has an invalid path? It should be highlighted in red. If you click on it you can see the path that it is trying to use.


#5

None.


#6

If it’s greyed out like that then it can’t find the module. If you click on one of them it will show the path it’s trying to use.


#7

After turning on “Use global path for this module” for every module, it worked.
It’s strange that this wasn’t the default behaviour. Thanks for your time!