Xcode 10 feedback


#1

Is xcode 10 working fine for you guys? any particular issue?

for me, clicking on an error/warning in the navigator would not reveal the file & line in the editor. I’ve reinstalled xcode9


Xcode can't find some methods
#2

Yes, Xcode 10 is a total car-crash - we’d recommend avoiding it. None of the long-standing bugs are fixed, and there are many new serious ones like breakpoints not working, new crashes, not being able to jump to errors etc.


#3

I’ve fired off a bug report about this. It’s pretty stupid: if the header search path leading to that file is relative then you can’t jump to the error. If you modify all your search paths to be absolute then things start working again.

I also had a consistent crash as soon as I typed #include <../../some_file. with an internal assert triggering due to the path not being absolute.

Furthermore the debugger was breaking on assertions, but jumping back to the wrong place and it at least appeared that some previous lines were not executed.

I discovered all of those within about an hour of usage, including filing the bug report. The only conclusion I can draw is that Apple does not do any testing for C++.


#4

I’ve been running the beta for a couple of months and it seemed to be working okay, but the latest release just seems to have broken everything.
Feels like the initial Xcode 9 release all over again


#5

There is also this which relates to rebuilds not being triggered when user modules are changed.

If someone can hazard a guess as to why this might be happening, I’ll gladly file a bug report with Apple.


#6

I decided to update this morning because several of my devices are iOS 12 now; I’ve experienced two main issues trying to build iOS targets:

  1. If you try to archive from an existing project (one you have archived from before) it throws the ol’ “can’t create a symlink” error for the appex. I solved this by completely trashing the build folder and letting Projucer generate a new one.

  2. Archive again, but the archive it creates isn’t an App Store archive, but rather that old school one that isn’t good for fuck all. This isn’t consistent; I tried some projects and they archived correctly, and others, for no particular reason I can discern, do not. Naturally, the one I need to update is of the latter sort. Short of creating an entirely fresh project, I’m not sure what to do.

Bleah.


#7

Further to this, I can’t track down what is going on exactly, but the #2 issue I’m having above appears to be a JUCE bug.

Steps to reproduce:

  1. Trash the build folder of an iOS project.
  2. Use the Projucer to generate a new one.

This will result in a project that builds to the device and simulator properly, but doesn’t Archive correctly. I tried this with both Xcode 10 and 10.1; rolled 10 back to 9.4.1 so I can’t provide further testing on that at this time, but I can check 10.1.


#8

OMG I still roll on XCode 8 because I heard horror stories about XCode 9. How is it possible that a software gets worse with each update?


#9

#shitshow #xcode9alloveragain #almostasbadasmicrosofttryingtodomidi


#10

Haven’t tried version 10 yet, but if you need the iOS 12 sdk you should be able to copy all the necessary files from Xcode 10 and use it in Xcode 9. This used to work for the past versions, check out stackoverflow for more info.


#11

haaaaaaa :joy::joy::joy::joy::joy::joy::joy::joy:


#12

It appears to be forcing me to upgrade, by saying

“Xcode requires additional components to support running and debugging. Choose install to add required components”
[Quit] [Install]

So I appear to not have a choice but to “upgrade” to 10. I remember this got me on 8 when I tried to run it. Is there a way around this annoying Apple thing?


#13

I don’t have that problem on 10.13.6 with xcode 9.4.1. are you running Mojave or something?


#14

The additional components install will not upgrade you to 10, just install some components for 9. I did a manual download of XCode 10 from the developer site and installed it side by side.


#15

Ok thanks i’ll try it today. I’m always a little suspicious of them not allowing something to run without an update, it’s very controlling - not like Apple at all! :roll_eyes::grinning:


#16

Xcode 10 refuses to build projects with 32-bit architectures enabled (doesn’t build the 64-bit architecture which it supports). So I’ve made a patch for Projucer to set the architecture to 64-bit only with Xcode 10’s SDK - https://github.com/soundradix/JUCE/commit/aaf6889546d3a1d2c1f8a3361fc3fb75bf75112f
(also available for JUCE 5 in our juce5 branch)

This way builds using Xcode <= 9 are unaffected but projects still build on Xcode 10 (albeit only in 64-bit)


#17

Motherf***ers!!! pressing [install] installed 10.0!!! I freaking hate Apple somtimes…

So basically I had no choice, to compile ANYTHING AT ALL I had to use 10.0


#18

Sorry about that - definitely didn’t do that for me :frowning:

Just go to your developer account and redownload 9 and install that.


#19

I might just slog through it, although my last completed plug-in product now has the following errors straight from the Projucer in 5.3.2: These files do exist on the system but…
39


#20

There is only 10 available and 10.1 beta in my dev account.