Xcode 10 feedback


#21

https://stackoverflow.com/a/10335943 might help.


#22

Oh you’re a life saver, thanks man! Now I’m wondering if it’ll start wanting to upgrade me all over again…


#23


#24

OK getting to the root of my 10.0 problem, well at least it compiles now! It appears I needed to re-select all my ‘global paths’ in Projucer as the SDKs were suddenly completely wrong and the modules now need the user folder included in the name. So ‘~Juce/modules’ is wrong, it needs ‘/user/name/Juce/modules’ now


#25

Xcode 10, just jumped in on my mac. The worst part is that this seems to mess up Clion (xcode is like coding with mittens)

After saving in Projucer, Clion (cmake) now complains about this:

CMake Warning at /Applications/CLion.app/Contents/bin/cmake/share/cmake-3.9/Modules/Platform/Darwin-Initialize.cmake:121 (message):
Ignoring CMAKE_OSX_SYSROOT value:

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.13.sdk

because the directory does not exist.
Call Stack (most recent call first):
/Applications/CLion.app/Contents/bin/cmake/share/cmake-3.9/Modules/CMakeSystemSpecificInitialize.cmake:8 (include)
CMakeLists.txt:16 (project)

Anyone else got this?

(Project compiles in Xcode actually)


#26

@Nikolai I think this is because you have 10.13 SDK selected as the OSX Base SDK Version in the Xcode (MacOSX) - Debug or Xcode (MacOSX) - Release settings in Projucer. I guess selecting Default will make the warning go away.


#27

@McMartin
Hi
Thanks, but no, I have it do default, and even set deployment target to default just to test.
Projucer 5.3.2

After the warning the build fails with this:

fatal error: : ‘CoreFoundation/CoreFoundation.h’
file not found’CoreFoundation/CoreFoundation.h’
#include <CoreFoundation/CoreFoundation.h> // (needed to find out what platform we’re using)

I’m no expert on this, but when I open the application bundle for Xcode, the only sdk I can find is 10.14, and that is not an option in Projucer


#28

I think you may need to re-copy the SDK you were using before back into Xcode’s SDK folder. And for some reason, reset all the other locations in Producer, by selecting ‘…’ and mouse clicking the appropriate folders.
That’s what I had to do anyway, ¯| (ツ) /¯
edit someone posted a link to download all the SDKs a while ago I can’t remember where at the mo, sorry.


#29

The SDKs are here: https://github.com/phracker/MacOSX-SDKs
Copying in them will work, but it seems a bit “forced”. There has to be a reason why they go away from Xcode. Can’t we just add the 10.14 SDK in Projucers list ?
To be honest I’m a bit confused about the sdk version vs deployment target, we still have to support at least Osx 10.10 or 10.11, how will that work out if we use the 10.14 SDK, and how will the new versions of osx play with the old SDKs.
Sorry, I guess this is a bit off topic for this “xcode 10” post


#30

Quick question, is your autocompletion for includes not working as well?

If you type in #include<>

Then begin to insert your library name, like vector for example, do you get an autocompletion for it? I’m not getting any for most libraries.


#31

Hey @DaveH. I had the same problem(file not found). In my case, I’ve set up JUCE incorrect. I’ve copied only Projucer.dmg firstly, but If I copy whole folder(projucer.dmg should be inside it) then it works correct.


#32

@maslenkov I’ve completed two products with my current Mac Juce installation, but a latest-ish Mac update or something screwed up my Projucer folder pointers. Kinda weird though, I don’t quite understand what happened TBH.


#33

Take a look at this thread…


#34

Yeah, that’s exactly the problem. Don’t use the ~ character for the home directory. Projucer correctly uses the full path if you click on ‘…’ to change it.


#35

Sod this, I’m going back to 9.4.1.
I’m now getting the a crashes as soon as I start typing #include <emm…> - it can be anything to be honest. It eventually comes up with a crash log:

“Details: Path must be absolute but is not: …/…/JuceLibraryCode”

Process:               Xcode [3101]
Path:                  /Applications/Xcode.app/Contents/MacOS/Xcode
Identifier:            Xcode
Version:               10.0 (14320.25)
App Item ID:           497799835
App External ID:       828536089
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Xcode [3101]
User ID:               501

Date/Time:             2018-10-01 16:41:10.044 +0100
OS Version:            Mac OS X 10.13.6 (17G65)
Report Version:        12
Anonymous UUID:        D81061EC-2C90-6D01-365B-316C11F961D3


Time Awake Since Boot: 8200 seconds

System Integrity Protection: enabled

Crashed Thread:        9  Dispatch queue: -[DVTTextCompletionDataSource init] (QOS: UNSPECIFIED)

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
ProductBuildVersion: 10A255
ASSERTION FAILURE in /Library/Caches/com.apple.xbs/Sources/DVTFrameworks/DVTFrameworks-14317.18/DVTFoundation/FilePaths/DVTFilePath.m:908
Details:  Path must be absolute but is not: ../../JuceLibraryCode
Object:   <DVTFilePath>
Method:   +filePathForPathString:
Thread:   <NSThread: 0x7fdc4f440dd0>{number = 44, name = (null)}

#36

Yep, that’s the same crash I ran into.


#37

I just tried the Xcode 10.1 beta and it still doesn’t recompile when a file has changed in a module (referenced folders?). Sad.


#38

Anyone getting insta-crashes as well? I open a JUCE session, make a few tweaks and it instantly crashes and is totally repeatable, not random.


#39

auto complete is slow as molasses here. no crashes though…


#40

Yeah, what does the eventual crash log say? (mine takes a few minutes to appear, through embarrassment I expect! :slight_smile:)