Xcode 7.3 and older SDKs


#1

I've just updated to Xcode 7.3, and I'm having a little problem. I like to build my apps using the 10.7 SDK so that the app is compatible with older versions of OS X. I have a copy of the 10.7 SDK on my hard drive, and usually I just create a symbolic link to it in Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/ and it shows up in Xcode's "Base SDK" menu. But this time I can't see the older SDK. Has anyone else had this problem?


#2

Why you are using this old SDK? 

You can use the latest (base) SDK.

If you want to make the application compatible with older versions, set the "Deployment Target" to whatever version you need.

 


#3

Hmm. I was under the impression I needed to use the older SDK, but now you mention it, that does make sense. I'll try it, thanks!


#4

I have same issue and I can't compile with the 10.11 base SDK version, as XCode yell that "Finder.h:240:3: Use of class template 'Point' requires template arguments" and also "/Components.h:320:68: Reference to 'Component' is ambiguous".

When I did the upgrade to OSX 10.11 (back in January), I fixed this by using old OSX 10.8 SDK and waited to an update from JUCE team. They did the update, but I don't know for what reason, didn't work.

Do you may know a solution to fix this for good?

Thank you!

 


#5

I have same issue and I can't compile with the 10.11 base SDK version

Almost everyone who uses JUCE is using the 10.11 SDK, including ourselves, so it obviously the code works fine with it! If you have a problem then it must be something either in the way your machine's set up, or something you're doing in your own project files.


#6

When you search on internet how to compile for older OSX version you will find a lost of post where the recommendation is to set the base sdk to the oldest OSX version.

Some example:
http://openradar.appspot.com/radar?id=1850406

In the past, I did experience some issue on older OSX version when I was using the lastest SDK that was correstect simply bu using an old SDK.


#7

Since we ran into this I’ve add it to our bash update script with the following:

sudo /usr/libexec/PlistBuddy -c "Set :MinimumSDKVersion '10.6'" /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Info.plist

You can ofcourse set the minimum you desire.
(we only use it for RTAS lib funkiness) and it shouldn’t be use for 99.9% of the use cases especially with JUCE builds…


#8

This is, what I use to install older SDKs:

btw. I’m using the 10.7 SDK on OS X 10.11 and XCode 7.3. I’m going to use switch over to the 10.11 SDK as soon as I need to support AUv3 while I’m still implementing my plugin it feels more save to me to use the SDK that fits the deployment target. This way I get a linker error when I try to use functionality that is not available on the target platform.