AAX Library / Xcode Linker Error (OS X)


#1

Hi there,

I’ve got an old project here that was working fine last year on Xcode 7.0 / OSX 10.10… I’m now using 7.3 / OSX 10.11. It builds in debug mode no problem, but I am hitting a linker error building in release mode"

ld: library not found for -lAAXLibrary
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Does anyone have any ideas of why this error might have materialised? The position of AAXLibrary hasn’t been changed.

Thanks very much for any assistance. :slight_smile:


#2

Have you tried rebuilding the AAX library with the new XCode/OS version?

Rail


#3

Cheers Rail.

I haven’t successfully rebuilt the AAX library, so I’m guessing this might be the issue -

I’ve tried rebuilding AAXLibrary.xcodeproj, but I’ve been receiving the error

"The run destination My Mac is not valid for Running the sceheme ‘AAXLibrary’."


#4

This error sounds like maybe the “deployment target” setting is set to a newer OS version than you are running…


#5

As always, make sure your using same C++ lib. as AAXlib is compiled you must make sure you’re linking against correct libc++ or libstd++ . and each require to be compiled for both targets (Debug and Release)


#6

Thanks for the help guys - The AAX library needed rebuilding


#7

Hey there guys, I’m having the exact same error, the aax lib compiled successfully but the linking still doesn’t work. Thanks in advance.


#8

Did you read this thread? Did you build the libcpp target?


#9

Yep, matched libs, release versions, languages, but still no luck.
I went to the library search path and the only file that I found was libAAXLibrary.a in the debug path, release has nothing. It doesn’t seem right…


#10

What I do:

  • open the AAXLibrary Xcode project
  • Build the AAXLibrary in Debug mode, then in Release mode
  • Change the scheme to AAXLibrary_libcpp
  • Build it in Debug mode, then in Release mode

You’re done. It will now link with whatever C++ library you set in Projucer (LLVM or GNU) and in Debug or Release mode.

Hope that helps.


#11

It worked, thanks! Haven’t realised that AAXLibrary_libcpp wasn’t set to build at all.

Much appreciated.