AAX Release Build fails

Hi,

I’m working on a Mac with Xcode 11. I can successfully build my JUCE AAX plugin in Debug mode. But when I’m changing the build configuration to Release, the build fails with the following error code:

ld: library not found for -lAAXLibrary_libcpp

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Does anyone have an idea what is wrong?

As it is working in Debug config, the AAX lib is obviously present, so maybe there is something wrong in the build settings but I don’t find anything.

I also tried the Juce example codes, it’s the same issue, so it’s not my code.

Many thanks,
Stefan

Did you build the AAX lib twice? Once in Debug and once in Release.

1 Like

Oh man :man_facepalming: stupid me …
that was the problem. I only built the AAX lib in debug.
Thanks McMartin!

Hi,

I have Xcode 12.4 and I cannot build my JUCE AAX plugin in debug mode. But I still get the exact same error. I do not know what is wrong.
First I added the AAX plugin in projucer and when I run it it fails with over 20 errors. Then in Target AAX project and in Build Settings, I added arm64 and arm64e to the Excluded Architectures and now I get the same error.
Any idea? Really appreciate it.

My issue was fixed. I did not know that I had to build the AAX SDK. After doing it, it worked.