AAX plug-in isn't built on Windows


#1

I should say first of all that I’m a beginner with Juce, I’m working on Windows 10, using VisualStudio 2013 and Juce 4.2.1. If I create a project which builds VST2, VST3 and AAX variants, the VST2 and VST3 are built but not AAX. There are no errors. I’ve got the AAXSDK and have built the DemoGain AAX example plug-in.


#2

Silly question, but did you actually enable AAX in the project settings?


#3

Yes :slight_smile: The project is quite old, created a year or so ago. I just tried creating a new project with the same result - no AAX plugin built (although I don’t know where it’s supposed to be placed anyway - it’s not in the 32 or 64 bit AAX plug-in directories or the VisualStudio2013 “Release” directory.)


#4

You have to create the aax bundle yourself, from the dlls that you have built.
see other threads, such as :



No AAXPLUGIN file/folder created - SOLVED!
#5

Thank you.


#6

But wait! I still don’t understand this fully. The VST2, VST3 and AAX versions are all contained in one binary (I finally understand why the dll is so big!) - why is there a copy of the .dll which is renamed to .vst3, but no copy renamed to .aaxplugin? Should there be?