'AAX_Version.h' file not found

When I try to create basic plugin in Projucer I keep getting the error ‘AAX_Version.h’ file not found. I am trying to build an AAX plugin so I can use it in Pro Tools. Does anyone know how I might be able to fix this error and build an AAX plugin for ProTools?

Did you register yourself at Avid, applied to become an AAX developer and downloaded the SDK from the internal Avid developer area?

1 Like

I believe I downloaded the AAX SDK and tried to build the plugin, but am still getting the same error. Is there a particular SDK I need to download or put it in a certain place when I build the plugin?

Thanks so much.

Did you specify the path to the AAX SDK in Projucer (either via Global Paths or in the exporter)?

Hello. Thanks for getting back to me. I specified a Global Path to my folder with the AAX SDK, and it seems as if I am not getting that error any longer. I am now getting an error that says

clang: error: linker command failed with exit code 1 (use -v to see invocation)

How do I resolve this?

If you get a linker error it sounds like you did not actually build the AAX SDK before trying to use it in your juce project, so that the headers are there but the linker fails to find the library. The SDK you downloaded should contain everything you need (e.g. Xcode and VS projects) to build it. Further discussion specific to this should be held on the internal Avid developer forums, as you and all other users signed an NDA…

Did you figure it out? I’m a beginner with similar issues… not sure I’m specifying the global path correctly.