Add macOS 10.14 (Mojave) deployment target


#1

I recently updated to macOS 10.14 (Mojave), and by default, couldn’t compile any projects as the Projucer only lets me select the OSX Deployment Target 10.13.

The workaround was to download the older SDK and move it to the corresponding location in the XCode.app package, however it would be nice to have support for macOS 10.14.


#2

If you edit the source for ProJucer, you can add the appropriate export target as needed until the JUCE team add it to the development tip. I did that with ProJucer 4.3.1 so I could compile with c++17. It took a little digging to find the right combo box, but was pretty easy to implement once I found it


#3

I’ll get that added now.