[FR] JUCE modules and Deployment Target check

#1

Hi guys,
we noticed that you can set your Deployment Target to a system that will not support the selected C++ version. An example: C++14 against OSX 10.8. The plugin will build, but it will not load under OSX 10.8.

EDIT: After some tests, the issue is related to a JUCE module that requires 10.9 as minimum target, while the C++ version is not causing any issue.

It will be very useful to have Projucer warning you if such condition is met.

Thanks

0 Likes

#3

I’ve built applications with Xcode 7.3.1, using C++14, targeting macOS 10.7 and they were running fine.

Are you including the juce_video module in your Projucer project? That module requires macOS 10.9 to run because it depends on AVFoundation.

0 Likes

#5

Thanks McMartin. In an initial test, removing juce_video didn’t helped… but looks like it was the responsible for the compatibility issue.

0 Likes

#6

I disagree. The feature request makes sense, but should be amended to “JUCE modules and Deployment Target check”. Projucer could totally warn that using juce_video requires macOS 10.9.

0 Likes

#7

I edited the thread title and the content to reflect what we discussed above.

Thanks again, McMartin

1 Like