Limited by old macbook. Can I use Juce?


#1

Hi all, I hope this is the right place to post my first question.

I have an old macbook and therefore limited to osx 10.7.5. Can I still experiment on the Juce platform? I see that the current version is for minimum osx 10.9. Is there an older version where I can get started?

Thanks.


#2

10.7.x should be fine even with the latest version of JUCE, I think you’ll just find that the Projucer (and maybe other projects in extras and examples) have the OSX Deployment Target set to something higher than 10.7. The Projucer has it set to 10.9 for debug builds but 10.7 for release builds. Building against 10.7 shouldn’t be an issue to the best of my knowledge. I believe if you want to, you can set this to be as low as 10.5! but I would suggest not dropping below 10.7 as then you can use C++11.

You can see the deployment target for the release configuration is set to 10.7 in the image below.


#3

Unfortunately, although JUCE projects can target older versions of OS X, actually compiling JUCE code requires a modern compiler and I suspect that the most recent version of Xcode that will run on your machine will be too old.