Aftertouch not recognized

I run a beta where users report that (poly) Aftertouch is not recognized by the plugin. I don’t have a keyboard which is capable of aftertouch so it is kind of hard to debug…

I tried injecting artificital MIDIevents into the MIDI-queue

int aftertouch = 160;
int note = 64;
int value = 127;
for (int sample = 0; sample < buffer.getNumSamples(); ++sample) {
 	midiMessages.addEvent(MidiMessage(aftertouch, note, value), sample);

These values get properly regognized by the JUCE funcions:

bool MidiMessage::isAftertouch()

Yet the users report it is not working. I even had one of them log the MIDI-events the controller was sending and they matched the scheme perfectly!

Now my next steps would be:

  1. ask the lovely people on JUCE forum if they know what could be wrong / have any help
  2. tinker around and build and Arduino device which is capable of sending Aftertouch
  3. Buy a MIDI-controller with poly-aftertouch

I can’t suggest why aftertouch is not being recognised, but in terms of testing in the absence of an aftertouch device, you could try ReaControlMidi plugin by Reaper, it’s part of the free ReaPlugs FX Suite. If you put it before your plugin in the FX chain you can send aftertouch midi events to your plugin.

1 Like

Uuuuh nice one thanks!

Just wanted to note that ReaControlMidi is not capable of Poly Aftertouch:
Poly Aftertouch is a separate control type, outside of CC. It can send channel pressure though.

Anyway, it seems “Channel Pressure” is the Aftertouch people are looking for these days, while “Polyphonic Aftertouch” is a thing of the past? Why would a superior polyphonic format be dropped for a mono one?

I consider simply dropping the option for polyaftertouch in my modmatrix if it isn’t used anyway.