Any Rez (.r) dependency removal?


#1

Hi, I very often encounter problems compiling my audio plugin project related to the Rez command. The problems encountered are really boring, they usually came on monday morning with no reason while the project compiled correctly on last friday… do not ask me why. I had all the problems you can encounter like “failed to find AUResources/AUResources.r” (see http://www.rawmaterialsoftware.com/viewtopic.php?f=2&t=9613&hilit=Rez) or more recently “CoreFoundation.h” file not found within the Rez building command (http://www.rawmaterialsoftware.com/viewtopic.php?f=2&t=9132). Usually, (on monday typically, still do not ask me why… probably an automatic update happens in my back) Reinstalling the XCode tools solved several times the problem, but today it did not worked out. I therefore had to come back to a previous backup version of XCode which by chance was able to compile the project… but still that is a dirty workaround and I know for sure that “a day” my project will not be able to compile anything and I will simply keep stuck on this for a whole day until reinstalling everything will probably solve the problem “by chance”. Ok here is then my question:

As I understood the Rez is a legacy command which purpose is to compile stuff for carbon. Given most of us are not using PPC anymore, is there a way to bypass this step ? I can be wrong but as I understood even apple got rid of the .r support in their latest right ? I read this thread (http://www.rawmaterialsoftware.com/viewtopic.php?f=2&t=9028) but it does not really helped me understand what to do.


#2

I’ve never actually had any problems like that, so am not sure what to suggest. Yes, Rez is a legacy tool that will eventually disappear, but it’s required for x86 builds too, and to support 10.5 AUs, etc.


#3

Ok I will try to update this thread if I can get from where comes the problem


#4

Just had such an error, it was the case of the “Developer/Extras” folder disappearing inside my Xcode.app

Repeating the step

sudo ln -sv /Library/Developer/CoreAudio /Applications/Xcode.app/Contents/Developer/Extras/

from the instructions at http://rawmaterialsoftware.com/viewtopic.php?f=8&t=9546#p56677 solved it.

in this case removing the rez step wouldn’t had helped as all the other AU files were not accessible as well.