Anyone knows how to use break points on XCode 6?


#1


Anyone knows how to use break points on XCode 6?

Setting break points in JUCE source code doesn't work. Setting break points in our own source code works, but only for some files.

Creating an ~/.lldbinit or ~/.lldbinit-XCode file (suggested on http://www.juce.com/forum/topic/xcode-breakpoints-not-hit-juce-source-code) has no effect, executing "settings set target.inline-breakpoint-strategy always" from the lldb command line doesn't have any effect either.

It doesn't make a difference wheter we launch lldb via XCode or just from the terminal.

--
Roeland

 


#2

Have been happily using breakpoints in Xcode for years.. It does sound as if you need to follow the advice in that thread - maybe you just made a mistake in editing that file?


#3

Maybe our project is set up wrong. It is set up directly in XCode (and Visual Studio on Windows). It's not possible for us to use the IntroJucer. Do you know of any custom settings to allow debugging in the projects generated by the IntroJucer?

I can set breakpoints successfully only on some of the source lines. For instance here in juce_TextEditor.cpp:

    bool TextEditor::keyPressed (const KeyPress& key)
    {
1→      if (isReadOnly() && key != KeyPress ('c', ModifierKeys::commandModifier, 0))
2→          return false;

3→      if (! TextEditorKeyMapper<TextEditor>::invokeKeyFunction (*this, key))
        {
            if (key == KeyPress::returnKey)
            {
                newTransaction();

                if (returnKeyStartsNewLine)

If I enable 1 it never breaks. If I enable 2 then it will break when I press Enter in the text box, but it will break on line 3 (and continue below if I step).

I have verified via the lldb command line the .lldbinit file is read correctly.

I don't think I have any optimisation enabled. I have the Build Configuration set to Debug in the Scheme Editor, and the compiler is definitely using -O0 and including debug symbols. I'm not sure if I need to change any linker settings.

--

Roeland


#4

Hey, did you even fix this? I've got the same problem. I've definitely patched the lldb file correctly. I'm using the latest XCode 6 and Yosemite.

 

Thanks


#5

Definitely running in Debug build with -O0?